Andropilot - discussion for Android ground controller users/developers

Hi ya'll,

The thread on my blog post is getting a little unmanageable.  How about we discuss test results here instead...  

I'll also post release notes as new builds are out.  The device must support 'USB host mode' (most devices running android 3.1 or later are fine).  You'll need a 'OTG' adapter such as this

Please post feedback here or on the github issues site - the google play comments are not really useful yet.

Hi ya'll.  Please move further discussion of this app to a newly created group:

http://www.diydrones.com/groups/705844:Group:1132500?xg_source=msg_...

Feel free to make new approprately titled discussion threads.  

Future app releases will be announced only there.

 

Views: 55172

Reply to This

Replies to This Discussion

There also seems to be a bug that causes the aircraft position to lag the true position by quite a long way. Perhaps there is a buffering problem on the mavlink connection to the radio? Are you assuming a stream rate, or just reading messages as fast as they come in?

Hmm - this might be because of how I setup the stream.  When I open the connection to the 3dr radio one of the first things I do set a very slow poll rate (1Hz).  Two possible problems:

  • The mavproxy tunnel/software simulator is ignoring this and then messages are queing up faster than I can dispatch them (though I presume I should be able to get through them pretty fast)?
  • I should ask for position updates at a higher rate (though this is kinda the opposite problem of backing up).  I only just realized that the stream rate parameter is interpreted as a frequency rather than a period...

Kevin,

I am testing 1.30 and I no longer am receiving MavLink Data. It seems after 1.27 something changed now in the Vehicle View I get no info, in the Status Message I get "looking for vehicle" if I back install 1.27 the data comes back, if I go past 1.28 no joy. Did something change in 1.29 and 1.30 in regards to how you pull data down from the APM through the 3DR - polling rate, anyways....I am not able to resolve it, I will post logs but since I am not receiving any data I am not sure that will help.

Also does Vehicle Overview require that APM have GPS 3D Fix before any data comes in ? and does the radio have to be on? 

Let me know your thoughts.

This is on Acer Iconia TAB500 with Android ICS 4.03

Even better than the 'speach' stuff it uses the 'speech' stuff ;-)

I agree - no need for logs.  Does the blue airplane icon appear?    Can someone else report problem or success with 1.30?

I get the blue plane. but no data. status looking for vehicle

No info in Vehicle Overview

Status Messages

Looking for vehicle

only a few Params

First- Great idea and very cool app.  I just DL'd from GPlay store and opened it for the first time.  I connect my xBee unit to the USB port and the tablet asks what app to use to open the modem- I select 'Andropilot' and it loads right up, finds the xBee and the status changes to 'looking for vehicle' in the status window- I do have the blue plane icon.  After five minutes the status hasn't changed yet.  I see no params or anything.  I look forward to seeing this one work as this is another exciting moment in the evolution of personal UAV's.

To get to params:

  • put tablet in landscape orientation
  • swipe your finger across the right info panel, it should move over to params.
  • What do you see there?  A spinning circle, blank, some params?

can you try the steps I listed below for Eric and post what you find?

Yes in landscape, was able to change between, overview,pram 

just a very few param not as many as before mostly blank with ?'s

Got blue plane some times it turns red, home icon appears

Check by plugging radio into laptop and mission planer all is working

running on Thrive

Update- tried it again and now I get GPS data and a full list of all params. Status still reports 'looking for vehicle' though.  This is very cool  :-D

rebooted everything.

get message receiving mavlink data

spinning circle for quit some time then most Param now show up

Apm has 3d lock but no overview data

status message is looking for vehicle

 

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service