Andropilot - discussion for Android ground controller users/developers

Hi ya'll,

The thread on my blog post is getting a little unmanageable.  How about we discuss test results here instead...  

I'll also post release notes as new builds are out.  The device must support 'USB host mode' (most devices running android 3.1 or later are fine).  You'll need a 'OTG' adapter such as this

Please post feedback here or on the github issues site - the google play comments are not really useful yet.

Hi ya'll.  Please move further discussion of this app to a newly created group:

Feel free to make new approprately titled discussion threads.  

Future app releases will be announced only there.


Views: 55272

Reply to This

Replies to This Discussion

Yeah - 4Hz (or faster) should really be no problem.  However, I think you discovered two related things:

  • The main problem: Almost certainly I recently introduced a problem where I refill the waypoint table repeatedly (this presumably burns lots of cycles in the GUI thread and the queue of messages for it starts to back up).  At least this is what my pondering while driving to work told me - we'll see tonight when I look at the code.
  • The secondary problem: There is a very annoying bug in android's USB stack that makes it impossible to know the # of bytes that got filled in a URB.  I work around this by having my FTDI code keep a bunch of small URBs queued up with android, and then (ugh) scan through the returned buffers for the 0xfe character (being careful to prefill the buffers with !0xfe).  

Everybody that wishes for a fix, click the bug and star it (click the star in upper-left area)

actually - that is a pretty good idea ;-)

Update: 2/5/13 New beta released (I think this will be a pretty good build) - You can download a binary from github.  Or wait a few hours and it will be up on the play store.  

# 0.1.31

* Add speech output
* Add HUD display (in portrait mode)
* Fix nasty USB performance problem - we can get a very high packet rate now
* Fix a problem where I was inadvertently never dequeing something from a worker thread (really nasty)
* Set background colors on overview screen, so hacked up android builds will work better
* Bump up stream rate on RC and stuff I need for the HUD

For next release:
* Do something to allow waypoint list selection with action bar ( )
* Show heartbeat lost on the overview screen
* FIXME: fix udp receiver
* FIXME: add waypoint change type (via menu dropdown)
* FIXME: make a website
* Change waypoint icons as appropriate...
* FIXME: Use a state machine to ensure we don't get confused if someone moves a waypoint while we are busy uploading new waypoints
* Clean up package namespace
* Show docs on parameter names (if possible)
* Handle the 'unusual' waypoint representations - look at mavproxy code for clues

Actually - I found a pretty nice workaround... So everything should be a lot better now...


App starts, connects with radio but no data transfer, no action in HUD as well.

Worked on earlier version, I got a ble plane, now it's red.
Upper right menu/modes shows unknown ??

Tried with both 433 & 915 mhz radios, same same

Says logging to file and 3DR connected....

Ok - I fixed the nasty throughput problem.  Things should be a lot better now (especially for the cdc-adm link that is used for direct APM connection).   For the 3dr radio connection it should also be much improved - but I still haven't copied the stuff that libftdi does to switch to 512 byte usb packets rather than the default ftdi limit of 64... Someday...

Hmm - one of the things I did to make things hugely better was to workaround an android bug.  It works _great_ on my device which is running 4.2.1.  Can you check the version of android on your machine?  Settings / About phone?  Also - can you try unplugging and replugging the USB connection and see if that helps in your case?

also - please also try a direct connection to the APM if you can.  It will be interesting if only the 3dr radios are not working...

no data here either... hud looks good. android 4.1.1 Pipo S2...has been working up to .27


Direct connect via 3dr works all the time.

Disconected&connected USB many times, same problem

Using Samsung N7000 Note

Android 4.04

Kernel 3.0.15-N7000XXLRI-CL811902

ok - datapoints from others appreciated.  I think my cool new way of getting much faster USB will only work on android 4.2.  Tomorrow I'll add back the nasty hack I was previously using, but only turn it on for <4.2.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service