Hello all,

I have spent last night and this afternoon and evening on this. I have read everything I could find and tried everything that was offered. I just keep getting waiting for Mavlink on both of them?

APM 2.5 (brandnew) and APM 2.5 1 month old.

MP 1.2.45,  mav 1.0.

2 x Minimosd 1.1 with V2.0 Firmware and latest charset and tried minimosd extra, and 1 x RCtimer Mavlink osd.

I a not running 3DR although I do have them.

I take it that the pinouts of the Telem Port from inside are Vcc,Tx,Rx etc running Tx - Rx and Rx - Tx etc.

1 APM is for Arducopter and 1 for Ardupilot.

I got the minims yesterday and when I first plugged them in they both worked fine. I wanted to try extra so I uploaded it, changed the parameters in MP as per wiki for minim extra and didnt work for either copter or plane.

Reloaded minim hex and charset on osd, cleared eeprom and factory reset in both APMs and still nothing? I have changed rx-tx pins on the cable and still nothing.tried with 12v to digital side for charset. I have tried reset.

What am I missing. As it worked when I first got it I thought factory reset would do the trick as it just worked when I first got it. 

Views: 1747

Reply to This

Replies to This Discussion


Video is crystal clear so its only the OSD overlay. I know there are many posts on this but none of those helped me this time

What do you mean on "both" of them, who are the both, both for me implies two ?

Im having the same problem. My hex has a 3dradio which feeds the osd( i got it like this from udrones). When i have my "other" 3dr on my computer on the "waiting screen" disappears and i get the screen i configured using the tool. The camera and overlay is perfect, im trying to fix the "waiting screen problem" just like Damian.

I flashed my osd(minimosd) with the latest version and the same thing happens. My understanding is the 3dr on the hex is trying to find its other half and for whatever reason doesnt send any telemetry, so the osd has nothing to show.

Not knowing much, the only solution i can think of and have it show something meaningful is to reroute the osd straight to the APM. Does this make sense ? Can we insert a splitter that so the OSD and 3DR both read from the APM instead of daisy channing OSD <- 3DR <-> APM ?

The minimosd naturally has nothing to display. Is there a way to have the osd take stuff from the How can one fix this ?

With the 3DR radio you can daisy chain it to the OSD and leave the Tx off the minimosd. Some people are using the UART on the board for 1.

I now have perfect OSD overlay with the beta revision but no mavlink data and my 3DR radios no longer work?

I have have spent hours researching on how to see if the tele port is working. I have voltage on the pins.
I have APM1, 2 and 2.5 over the years and I find that the documentation is such a mess now there is very little definitive information. I see many people who are just getting into it ask questions that could easily be answered with better documentation.
This is the first issue I hav not been able to solve

Did you try using the minim osd extra firmware ?

I update last night (2 April 2013) with arducam f/w version 2.0 and yet the wiating for heartbeat message display the logo with a 1.0. Mighty confusing. 

How does one really know the firmware version from looking at the OSD ?

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service