APM 2.0 Died overnight! Flased both Mega2560 and PPM encoder and still dead !!!

Hi Guys.


Just a requiste if someone else has encountered this. last week saterday I flew my APM 2 in a plane all was fine, and today I tried updating firmware and it did not work anymore over USB when clicking on the firmware of my choice, (acro) it would down load from the internet status would change to " reading hex file" that would then go to about 90% and then it will report a " communication error" . I have tested on two different PCs and then I tried over 3 Dr radio ! it works ! but I can not change any settings via Radios just read info.


I then found a few blogs about reflashing the chip sets on the APM board , I reflashed both Mega chip and PPM encoder but still no change.


Anyone any idea ?

Views: 1103

Reply to This

Replies to This Discussion


Can you describe what you did when you successfully reflashed? With an ISP programmer? What did you flash, bootloaders?

Do you know Arduino, do you have it (the special Ardupilot edition) and can you upload a simple example sketch?



OK so you used an SPI programmer.

We need to identify what is wrong, and you could be a little bit more diagnostic :) Tell in more detail what is working under which conditions and what not.

Do the LEDs flash like normally? Or at least light up? --> Then the CPU can run the firmware. Actually you can just fly off then. With an ISP programmer you don't need a bootloader.

Can you connect in MP? ---> Then the serial port is OK. Which ports (radio, USB, UART2.....) are working and which not?

Are you trying to update FW over a 3DR radio? Any reason not to want to use USB?The bootloader (firmware update) will generally only work over USB. Theoretically you can also use UART0 if you manually press reset in the right moment. USB automates that.




OK it was pretty unclear to me what was working and what not... that would only let me produce unclear and useless answers.

BUT - since you have an ISP programmer and you know how to code an AVR - I suggest you try find out if the UART0 port is working over USB to your PC or not.

You can compile the UARTDriver.pde sketch (in the libraries tree in ardupilot) in the special Arduino for ardupilot (available on github.com/diydrones). I'm sure you know all about how to do that. If you turn on  verbose compilation (Preferences) you can see where the hex file is written to. Flash that with AVR Studio. Open a terminal (TeraTerm, HyperTerminal or similar) on the APM USB interface, no flow control. 115200 baud. Press reset on APM. Do you see the text in the sketch, do you get echoed back what you type?

If you run into problems compiling or whatever, use a basic non-Ardupilot Arduino serial example.

If it will compile and flash but not communicate to the PC, I see the possibilities: 1) Hardware problem somewhere on APM, 2) The PPM encoder does not set the mux right (there is a mux that selects whether UART0 goes to/from USB or not), or 3) PC driver problem.



Hi Johann.... Any news in this thread ?


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service