I got this APM from my professor which apparently was working last semester but running into issues:


-I hooked up everything according to the beginners guide on the site (GPS,Receiver, ESC's)

-I downloaded the MP, installed all the arduino drivers, and the computer registers the Mega 2560 on my COM7, which I specify in the Firmware wizard at 115200 baud

-When I connect the USB serial connection, the blue and yellow LED's blink momentarily, then the TX starts to blink at about 20 Hz, while the RX will turn on and off every second  (The GPS and the receiver both register power to their respective units)

-Then the blue and red LED's blink very quickly for less than a second, then alternate back and forth at about 5 Hz for around 10 sec, then the Red LED blinks steady at about 2 Hz.

-The RX and TX LED's continue to blink continuously as described above

-If I send data through the serial port the RX will register it

-When I try to install the firmware it will detect the board version then download the software, then it will get to the "Reading Hex" step then fail with the bar at about 75% with the error "Communication error - no connection" (this happens on multiple PC's)

-Then when the mavlink tries to connect, it goes through the timeout countdown then says "No heatbeat Packets Received" (this happens on multiple PC's)

-When I disconnect the serial connection, then connect the battery (with the PM cable disconnected), the LED's flash as described above, including the TX and RX LED's (wierd!), and the motors make the ARM noise - it behaves similarly when I connect the PM cable from the power regulator to the ardupilot


I'm pretty new to the Ardupilot platform, so I am having trouble figuring out what tools I have to determine whether the board is dead, a serial driver isn't working, or I have something connected wrong on the board.  Help!



You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –


  • hi all, 

    im having the same problem on my apm 2.6 after tryed to load sbus encoder in AT 32u2...only green led is solid, red"A" lad just a couple of blinks then turn off. I will use the "Toshiharu TF" method with this usbasp 6 pins programmer.

    Do u think it will work? i have to plug in the higher header near micro usb port right? 

  • I had the same problem with my APM 2.5 when I use Mission Planner it fails every time about 3/4 of the way through the upload process.

    I found that if I run APMPlanner2 it works perfectly and completes the firmware upgrade, the only issue is APMPlanner2 is several versions behind, so if you start the process on Mission Planner choose your version and start burning the firmware until it fails, the file is downloaded to "C:\Program Files (x86)\Mission Planner\firmware.hex" or "C:\Program Files\Mission Planner\firmware.hex" on a 32bit machine. You can then go into APMPlanner2 and load a custom firmware and choose the firmware.hex from the Mission Planner folder, it's a little bit of work but at least you dont have to do it very often...

    Hope this helps

  • Hello,

    I ran into a simillar problem. My APM2.6 would connect via Mavlink without issues, but I couldn't upload any firmware. I tried to upload the latest firmware via an external programmer (usbasp) but i didn't work and worse thant that I erased the old firmware and my APM2.6 was useless.

    I tried reflashing the bootloder using the Arduino GUI and It didn't worked. I was about to give up but then i tried old school. I reflashed the bootload using AVRDUDE. Some of you guys may had heard about it. It is not nice, but is very powerful. I got to reflash the bootloader and then I was able to upgrade the firmware without problems.


    YOU WILL NEED AN EXTERNAL PROGRAMMER LIKE THIS ONE: http://www.ebay.com/itm/USBASP-USBISP-AVR-Programmer-Adapter-10-Pin...

    In this guide I will use windows 7 with the usbasp programmer. If you know your way with embedded programming, you know what to change. If not, stick to the guide.

    1) I use windows, so first install http://sourceforge.net/projects/winavr/files/  . Winavr install AVRDUDE and configure the systems paths. 

    2) Then, download the bootloader (stk500boot_v2_mega2560.hex) from here: https://code.google.com/p/ardupilot-mega/source/browse/Tools/APM2_2...  . Place it preferably in your c: root index

    3)Enter to DOS console by typing cmd in the windows menu.

    4) Make sure you are in the same directory as you .hex file. In this guide you .hex is in the c: root.

    5)Type this in the console: avrdude -e -c usbasp -p m2560 -U lock:w:0x3f:m  and press ENTER

       and wait until it finish.


    6) then type this: avrdude -v -c usbasp -p m2560 -U flash:w:stk500boot_v2_mega2560.hex  and press ENTER

       It will take some time to upload the bootloader to the chip.


    7) finally type this: avrdude -c usbasp -p m2560 -U lock:w:0x0f:m

    After this, go the the Mission planner and try to upgrade the firmware. If everything is fine, it should work.


    • This method is worked for me. thanks

    • Does anyone more make this and worked?

      Im having this problem:


      Does it solve my problem?

  • Hello,

    I just read the string of comment's on this page and the problems you've had with the "firmware". (I've had the same issue.) I have spent hours trying to solve the problem, reading, searching the internet for answers? I even reset my pc back to factory default settings. I cannot connect to my computer to load the "firmware" on the flight board. In fact I tried (3) different computers, running (3) different Operating Systems. None of them would connect to the flight control board/Mav-link connection?

    NOTE: The ARDUPILOT, "flight board" would light up when connected to the computer's using a micro USB cable. But! The computer would not connect to the "flight board"? (No MAV Link connection?) I also read that the firmware will not work with all motherboards? How true this is I do not know? 

    And in the Device Manager, there is nothing showing? No COM PORT & LPT. I also checked for hidden devices in Device Manager, and there are none? I just ordered another flight “control board”. But after reading all your comments I think I am going cancel the order? This “flight board” is just to problematic! You don’t know if it’s going to work or not when you use it?

    • I was wondering if the people who have successfully used these "flight boards", and had loaded the "firmware" on their "flight boards" without any problems..., would post what type of computer they where using and the Operating System on it? I'm just trying too narrow down what computer boards, and OS's work with this type of flight board?

      Thanks Joe...

      • Hi Joe,

        I've been able to interface my ardupilot with several computers, I've never ran into one which wouldn't work (obviously as long as ardupilot was functioning correctly). 

        I have interfaced with the ardupilot with an acer aspire one laptop running 64 bit windows 7, and with HP desktops also running windows 7, never used it on windows 8.

        I'm not sure if you've already tried the following steps for troubleshooting, but this is what I would recommend:

        -flash the boot loader http://ardupilot.com/forum/viewtopic.php?f=19&t=6064

        -check your voltage levels on the board - especially the voltage regulator

        -contact 3DR tech support (they will pretty much ask you to do the above then probably replace your board)

        These things are pretty fragile, good luck in resolving it.


        • Hello Nolan,

          I got the COM PORT & LPT listed back on Device Manager. It shows Arduino Mega 2560, but it has the “yellow” warning symbol showing also.  Which turned out to be a Code 10, driver issue, I did some more checking. Now either the firmware drivers are corrupt, or, the “flight control board” is defective? I have another “flight control board” ordered so I will be able to find out then what the problem is? Software or hardware…

          I tried flashing the "flight control board" last night, but no luck. But I will give it another go... thanks for the help!

          • Okay, I just "flashed" the flight control board with Flip. The computer detected the board, but it wouldn't install the driver's? *Just detecting the board was something...* Now just have too figure out why the driver's won't install

This reply was deleted.


DIY Robocars via Twitter
RT @donkey_car: Human-scale Donkey Car! Hope this makes it to a @diyrobocars race https://www.youtube.com/watch?v=ZMaf031U8jg
DIY Robocars via Twitter
DIY Robocars via Twitter
Jun 16
DIY Robocars via Twitter
RT @GrantEMoe: I won my first @diyrobocars @donkey_car virtual race! Many thanks to @chr1sa @EllerbachMaxime @tawnkramer and everyone who m…
Jun 13
DIY Robocars via Twitter
RT @gclue_akira: JetRacerで自動走行したコースを、InstantNeRFで再構築。データセットは別々に収集 #jetracer #instantNeRT https://t.co/T8zjg3MFyO
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: SPC 3.0 Now the motor also works. This car is doable. I just need to design a deck to mount my compute and sensors. http…
Jun 13
DIY Robocars via Twitter
RT @SmallpixelCar: My new car SPC 3.0. https://t.co/CKtkZOxeNQ
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: High speed at @diyrobocars thanks @EdwardM26321707 for sharing the video https://t.co/o4317Y2U1S
Jun 7
DIY Robocars via Twitter
RT @SmallpixelCar: Today at @RAMS_RC_Club for @diyrobocars. Used @emlid RTK GPS and @adafruit @BoschGlobal IMU. Lap time 28s https://t.co/R…
May 28
DIY Robocars via Twitter
May 15
DIY Robocars via Twitter
May 14
DIY Robocars via Twitter
May 13
DIY Robocars via Twitter
RT @f1tenth: Say hi to our newest #F1TENTH creation for @ieee_ras_icra next week in Philly. It’s going to be huge! 😎 🔥 @AutowareFdn @PennEn…
May 13
DIY Robocars via Twitter
May 11
DIY Robocars via Twitter
May 8
DIY Robocars via Twitter
RT @SmallpixelCar: Noticed my car zigzagged in last run. It turned out to be the grass stuck in the wheel and made the odometry less accura…
May 8