Hey everyone, I just received a Arducopter kit w/ full electronics, assembled it, everything is connected, installed MP, loaded driver, loaded 2.8.1 firmware. Problem I am getting is I cannot get Mission Planner to recognize the compass, doesnt work in Flight Data. Also the console reads No dataflash inserted  Compass Init Error. Attached are two screenshot I hope helps troubleshoot this. I hope the board isnt DOA.. The APM 2.5 came assembled in the case, but was missing 3 of 4 screws and the rubber reset button, bit surprised with this... Anyways, looking forward to any and all suggestions on getting this up and running. I am stationed in Japan and would like to see about troubleshooting this before sending it back to the vendor. Long mail times :P Thanks!

Jake

Views: 19802

Reply to This

Replies to This Discussion

To prevent this happening again, you can add a TVS diode such as NUP2105L, SMAJ8.0C, or 1.5KE600 on both 5V power input pin and 3.3V power output pin.

connect TVS diode anode to GND, and cathode to +3.3V and +5V, one diode per a power line is ok (for apm2.5 need 2 diodes totally).

this device can absorb  voltage spikes on signal/power line which can damage CMOS chips.

LDO TPS79133 use different semiconductor procedure so it is less robust then old stuff like LM1117IMP-3.3.

for knowledge about better circuit protection, try to get a old PLC such as Siemens S7-200 and see how they design I/O port

Have you got any photos of this procedure done to an APM? It would be good to see how it looks

Add me to the list of people hit by this 3.3 regulator problem.  I have one board that has been 'compass roulette' (sometimes being odd), and other board that reports 'No dataflash compass init'.  The first board has 4 volts across the output leads, the 2nd board has 2 volts.

I don't have the manual dexterity to successfully unsolder and replace the regulator myself.

Have You opened the ticket? I strongly recommend doing that.. 

However I must complain that Jani or anyone from jDrones still haven't replied to my problem .. It doesn't feel right being ignored.. :(

I still have not been acknowledged by jdrones, and will never buy anything from them again. I managed to fix my issue with the instructions above. I pulled my 3.3v reg off the ublox GPS that I got from them just to get it going. I am waiting for my 3.3v reg to arrive to fix my GPS so I can get my loiter mode working, also RTL.

It is really bad business to sell something and not support it. Or at least tell us its not warranty, I would have been happy either way. APM is a really good system, it flies really well.

PS

I just found something disturbing on jdrones website regarding warranty, it looks like you will have to either get it repaired or repair it youself :S

Warranty Disclaimer
This site and the materials and products on this site are provided "as is" and without warranties of any kind, whether express or implied. To the fullest extent permissible pursuant to applicable law, jDrones & Co. disclaims all warranties, express or implied, including, but not limited to, implied warranties of merchantability and fitness for a particular purpose and non-infringement. jDrones & Co. does not represent or warrant that the functions contained in the site will be uninterrupted or error-free, that the defects will be corrected, or that this site or the server that makes the site available are free of viruses or other harmful components. jDrones & Co. does not make any warrantees or representations regarding the use of the materials in this site in terms of their correctness, accuracy, adequacy, usefulness, timeliness, reliability or otherwise. Some states do not permit limitations or exclusions on warranties, so the above limitations may not apply to you.

I'm having the same issues w/ compass & data flash that def2att described Dec 2012. Any solution?

This worked for couple of us: 

 Buy TPS79133 chip in local store for cca 2 Euros... Here are instructions my friend gave me:

- using brute force and tiny scalpel - he removed chip from base (be careful not to damage soldering base - the square shaped shiny thing that you solder chip to)

- placed chip on the board (it's easy ay you have 3-legs on one side, 2-legs on other side - so you can't make mistake and place them in wrong orientation)

- using regular soldering station QUICKLY soldered legs to solder base I mentioned before. Used tinny tiny tweezers to touch leg he was soldering while soldering - effectively turning tweezers into heat pipe (so heat wouldn't damage chip itself)

Worked for me, was happy flying until I found out you shouldnt fly a multirotor without first balancing everything. Luckily, I just needed new bearings in my motors. Could have been much worse!

I stole the 3.3v reg from my ublox GPS to get me flying, its hard to get off, I have some precision cutters that I cut the legs with, soldering is the hard part. But the tweezers trick worked great.

Hi,

Can you please pass me the address of the store where you bought the ic TPS79133, I have the same problem and can not find shop that sell in small quantity

thanks

hey guys I have the 2.5 board, that will not connect to mp.  i check and i'm getting 4.7 volts out of my chip.  I assume this is bad....

I am having a lot of the issues listed here with my apm 2.5 board.  I can't connect in MP with the latest Arducopter V3.0.1.  I was able to load 2.9.1b and connect, however I couldn't run any radio calibrations.  The bars just stay empty no matter what I do, nothing records.  After reading a lot of these posts, I thought I would check the 3.3V regulator and this is what I get.  Any thoughts or help??

Inline image 1

im finding alot of 3.3v regulators but what mA did you use? 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service