guys im struggling to get my apm 2.5 quad in the air,


ive so fair diagnosed that the esc's wont arm and theres no output to them through the apm, have tested with other esc's and cli but nothing, ripping my hair out its been 4 days of testing and still nothing,


my auto calibration wont initialize and ive manually set each esc, used 2 different recivers and still nothing.



Views: 4871

Reply to This

Replies to This Discussion

Yeah Chris for trouble shooting i changed all flight modes to stabilize. can the board be armed with just being hooked up to the usb? or does it need the esc? if so will it arm with just one or does everything need to hooked up and ready to fly ?

steve my esc's are hobbyking SS series, ive used them many times on many different quads and many different boards, 

first time this has ever happened, the APM arms correctly but i do not have the second "BEEP" from my esc's, 

my solution -- my apm is powered by a bec on the input slot number 8

1- disconnect all power connected to the apm, 

2-plug in the lipo to power your esc's (they will go into signal state where they are looking for the signal to arm, they should beep continusouly an dslowly)

3 - plug in the power to the apm at which point the esc's will arm,

4 - arm your APM by selecting your programmed arm function, 

the esc's will now power and turn your motors, easy BUTTTTT!!!!! REMEMBER TO MANUALLY CALIBRATE EACH ESC INDIVIDUALLY THROUGH YOUR RX

also my problem was my waypoints had not auto loaded into MP and everytime i reconnect i am finding all my settings are reset any suggestions? i always power up and have a 30m waypoint

You can arm it while it's hooked up to the USB. If you've gone through the RC calibration and all was normal, the only thing I can think of is that one of your RC channels is reversed. It's really unusual for someone to have this sort of trouble with arming. Remind me again what RC gear you're using?

I GOT IT!!!!!!! my er9x is jacked up. I armed it but moving the right stick up and to the right. so I guess I will start working on the problem tomorrow. Thanks Chris and everyone else for your help.

Good! That just means your throttle is reversed. Reverse it from the Tx.

hey my 9x is setup with the rudder on the right side. isnt that wrong ?  throttle and rudder be on the left side right?

Hello DS,

I was curious what program you would use with that USBasp? avrdude? winavr? studio 6?

I have confirmed that I do not have my bootloader and want to load one and then update my PPM hex to the latest one.

Thanks in advance for your input!


Ok, I'll download Studio 6 then as avrdude comes with that.

Thanks !

I'll report back whether I get it to work or not.

Hi Drone,

reading your posts, I'm guessing your are the (my) go to guy with technical questions.

here goes 

I had a ESC which gave 8.5V on the 5 V I fried the APM2.5 board

There seems to be no communication on the USB port.

I exhanged the atmega32U3 and flashed it via ISP including bootloader

still no comms with USB. I can flash the 2560 via ISP ...but when updating via usb the green bar gets to the M of Marooned and then

communication error - no connection.

nothing is hot didnt see any magic smoke craterered black tiles ...

checked diodes fuses etc...

do you have a hint where to look ...the schematic is not very clear on how the usb communication runs to the 2560 via 32u2 ...

don't spare any technical jibberish ...i can follow :-)

Thanks, Wilfred

Hi Drone,

thanks for the reply 

its not that difficult on the 8 bit front, just fire up your soldering iron :-D

There are 3 Carmens on this site can you tell me which Carmen is the one to ask the questions to?

Thanks, Wilfred

I have the same problem with a flying wing and a hk esc, the motor doesn't  turn, when moving the stick, the motor beeps

btoh( motor and esc) worked the day before, but now I solved the problem with my elevon and the motor doesn't turn:(

your method didn't solve my problem ( no turning motor) with ss serie esc

when unplugging the esc from the apm and connecting with a lipo, no beeps

than connecting to the apm, on beep:(

I really need help so I can fly:(

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service