guys im struggling to get my apm 2.5 quad in the air,


ive so fair diagnosed that the esc's wont arm and theres no output to them through the apm, have tested with other esc's and cli but nothing, ripping my hair out its been 4 days of testing and still nothing,


my auto calibration wont initialize and ive manually set each esc, used 2 different recivers and still nothing.



Views: 4837

Reply to This

Replies to This Discussion

Have you been through the Troubleshooting Guide here? That covers all the usual setup errors that can cause this.

yes i have thanks for the reply, i just tried booting the board back through usb too check the settings now more errrs, the board wont pop up in device mananger or open a port, the board still powers and i can connect via radio to MP even though its powered on USB, but i cant load usb, tried resetttign and nothing.


just not my day

Please contact tech support from the store you bought it from.

its an rc timer board so i doubt they will be in the office,


Just hit reset, reloaded the arudino drivers and BAM, go tthe apm loaded via usb,


Now just have the problem of esc's that dont arm, pheww.

also i tested the output and with the apm armed and throttle rising i go from 2.8v to 4.6 v steadily, so theres output voltage just no esc's

I wish you'd said it was a RCTimer board at the start. That's a clone and we don't support it.

Post pictures of your wiring?

hey guys thanks for the help, im pleased to let you know i have a particular problem with my esc's i have to power them before my board to actually initialize them, i've adjusted all my PID's and have a successful quad, 

i appreciate your help, my next problem is my mission planner, everything works perfect except after a few flights my flight mode no longer goes into AUTO, every time it goes into AUTO it changes to loiter immeadiatley, i've recalibrated the radio and changed to swtiches instead of the petentiometer but nothing!,

any help would be greatly appreciated

And i'm definatley not discouraged this is my third quad and my first open source so to speak, its been a great effort to actually go from parts to a quad that sits stable at 50m for FPV flying, very very pleased. I just need to get this mission planner flight mode problem sorted ! cheers guys

yer its a 9x, its acurate on the radio calibration but jumping into loiter as soon as i it auto, although only just started doing this, 

any advice?

Jimmy I am having the same problem with the same board. I have had no problems flashing and setting it up or even with the flight modes. Just can't get the damn thing to arm. I'm working on my second tri. What the heck are pid's? And did you just power the esc and then plug them into the apm?
Those are the esc I'm using.

When you say it won't arm, do you mean the APM won't go through it's arming cycle (flashing LEDs, then a solid one when it's armed), or that once it's armed the motors don't turn? If it's the former, the problem is probably on your RC side. If it's the latter, it's your ESCs.

thanks guys for the super fast reply

chris- the red light blinks and i cant get it to arm(stay solid) but i can get my esc to auto calibrate.

Drone - mission planner shows everything is pointing in the right direction but i have moved the stick in all corners.

I'm still kinda of a noob but when i hook up my kk2 board everything works.

And you're sure you're in Stabilize mode? (Not one of the auto modes. For safety's sake it won't arm in auto modes. This is one difference between a full UAV and a basic RC copter.)

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service