Hey guys, I recently had to replace the hard drive in my computer and I've gone back to set up APM and MP. I followed the wiki as I did the first time I downloaded MP and everything worked fine. Now, after following the wiki, I keep getting "COM Port 4 does not exist" when I try to connect the APM board.   I went to Device manager and it seems that it is assigned to Com "Port 2, Hub 4" however, when I pull the drop down box in MP it gives me "Com Port 4 Ardu Mega" as the option. Any ideas on how to fix this. I have the latest drivers installed and the most updated MP.

MP Error.jpg

Device Manager APM.jpg

Drop Down.jpg

You need to be a member of diydrones to add comments!

Join diydrones

Email me when people reply –

Replies

  • 1.2.20 has a driver bug.  I got it fixed by downgrading to 1.2.19 and then going to C:\Program Files\APM Planner\Drivers and running the appropriate "bit" application which installed the drivers and it works now.

  • Also, I attached some screen shots. MP Error is when I click on the Firmware Ardu Plane. Device Manager APM is a screen shot of my device manager. (Note no com port assigned next to Ardino Mega and in the properties window, location is Com 2 Hub 4). The Drop Down show the options for com ports in MP.
This reply was deleted.

Activity

Hiroki Tanaka liked Hiroki Tanaka's profile
Oct 13
Derrick Davies liked lisa TDrones's profile
Sep 23
More…