Hi my APM 2.5 arrived today and I have just fitted to a new build frame, loaded new 2.7.3 and all running fine with the usb but when I try and power the board from the esc's I get the blue light flash 2 times then amber once then nothing.

If i connect the usb to the board with the battery connected all is ok and the board boot's up and then I can arm.

If i then unplug the usb with the battery still attached it remains in boot mod and I can arm.

there is a jumper on J1 I have checked and the board was fully assembled one

can some one please assist in this problem

Views: 12748

Reply to This

Replies to This Discussion

You would need to do it the other way around. i.e. bring up the APM first so the outputs were stable before powering up the ESCs.  Obviously that is a little difficult if you are powering the APM off one of the ESCs.

Mmmm. Ok I see the issue really is ESC that are not well programmed for a device that takes time to boot. The RC receivers that they normally power boot almost instantly.

Most of them have a delay time at the beginning where they don't respond and that gives the system time to stabilize but some of them will respond instantly 

Hi, first time post on here, I too have been having the same boot load problems and have tried everything separate BEC at different voltages, jumper J1 on and off etc. to no avail but last night I fitted a Ardupilot 3DR Radio Telemetry Kit 433Mhz and since fitting this my board boots every time without fail.

Out of interest has anyone else got the 3DR radio fitted and is still having problems with booting up?

 

Hey, hope everyone has sorted this power issue by now,

I got it working having previously experienced the same issue.

I had to do the following:

With USB power only and JP1 OFF

  1x : reset

  1x : erase

  1x: upload new firmware

  1x: Radio calibration

Then:

With: JP1 OFF

USB : OFF

Power:

 Input: UBEC (5V) from main battery

 Output: "4.8"V battery (standard NiMH receiver battery)

Stable and works like a dream. PID worked on my custom airframe fine first time, (although i I be adjusting them for next flight)

Amazing stuff

My APM 2.5 boots with USB, but not with LiPo. I measure 5.03 volt from the ESC, and 0,77 volt on the input rail.

If you ask me if there is a possibility that I have shorted something, the answer is yes, thats is possible, but not that I'm aware of. Any suggestions on what is happening to this board? I have a lot of APM 2.0, 2.5, 2.6, but this is the only one that does this.

To answer my own question after some measuring, the diode (yellow on pic) close to the jumper was faulty (probably because of me). I hope the only purpose of the diode is to prevent current both ways? I removed it and bridged the solder pads, and the APM is fine:) Guess I should replace it if I can find it somewhere...or maby 3DR could send me one in a letter..hinthint!

Attachments:

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service