Hi,

I received my APM 2.5 a couple days ago and followed the instructions to install mission planner here. Windows didn't locate the drivers automatically so I went to device manger, which shows Arduino Mega 2560 (COM7) with a yellow symbol next to it. I locate the drivers manually (Arduino MEGA 2560), and the following error code pops up: Device status: "This device cannot start. (code10)".

I have found two instances of this happening before (one of them here). Both of the fixes involve replacing a faulty USB cable. I tried using the cable from my phone (which I know works), to no avail. The APM is getting power though, since the LEDs are flashing (red&blue - orange, Green LED near GPS port).

I'm running windows 7 64 bit on my laptop.

Any ideas?

Martin

************************************FIXED******************************************

The APM 2.5 can't be started from the USB 3,0 ports on my laptop, but works fine from the 2.0 port.

Views: 1967

Reply to This

Replies to This Discussion

Hi, I used to have an AOM2 that did the same. Suspected hardware problem and replaced the ATMegaU8. That solved it.

You should of course not have to do that with a brand new one! Sounds like a warranty case to me (if you can't get it to work on a different computer either).

Your driver installation sounds correct. I have the driver and APM2s working OK on Win7 64 bit here.

Regards

Soren

Thanks for the reply. Turns out the APM 2.5 only runs off USB 2.0 ports, at least on my laptop.

Hi, great you got it solved... is the non working port a USB1 or 3?

3.0

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service