Hi all,

I am new to UAVs, I recently bought the APM 2.5, I have uploaded the Arducopter into the APM, if I try to connect via USB or the 3DR radios to mavlink, it does not connect, the error message is "No HEARTBEAT Packets Recieved", my baud rate for usb and radios i selected them correctly (115K and 56K), and i do not have the apm and radios connected to computer at the same time i.e if radios are connected to computer apm is powered via Esc. If i click on terminal it reads port is open, the board flashes LEDs 'A' and 'C' but if i type anything e.g test, pwm and hit enter nothing happens. as long as the board is powered on the LED 'A' is blinking. I tried reseting the board by pushing the reset button still no change in behavior of the board. Please HELP!!!!

I am building this UAV for my senior project.

Views: 9745

Reply to This

Replies to This Discussion

Delete APM 1.2.20 and then google APM 1.2.19 and download the .msi file. you will go through the download sequence and it will install 1.2.19. After that, go to C:\Program Files\APM Planner\Drivers and click on the appropriate bit version for your computer. The "Install anyway" screen will come up. Click Install anyway and it will establish the com ports. The com port # will now show next to Arduino Mega 2560 in Device manager. Viola! It should work. Mine does now.. and to think I missed the only good day to fly in the last three weeks because of this.. smh

did all this  I can see com 18 Arduino mega  but no communication with board 2,5 via USB  times out 

no heathealth  blbablabla.......this happened only recently with the uopgrade

eh Mr Osborne please help.....

did you follow my last post?

you may still have to upload the firmware again after doing the steps above to get it to connect. let us know.

yes  getting fed up  maybe the bord 2.5 is blown??  I do not like the way one has to connect disconnect the Lipo battery to synch the ESC   ...there must be a betterway.  this must have sent spires into the board even if using a separate supply (Jp1 off)

the PC cannot communicate with the APM2.5 I tried all ports and all baud rate . No luck

yet the board seem to still work ok  all three leds main are ok

any suggestion up there....


did you also perhaps have this problem after calibrating the ESC been  connect disconnect reconnect the Lipo battery pack?

did you use JP1 on?  I have a feel that this is the cause of spikes that damage the board.

Hammad  I have the same problem    I have found that UART2   the chip is opposite side of the silkscreen is blown

it has a tiny pinehole in it    as well as the diode just above IC2    

did you plug your USB to your PC with the lippo battery connected to the ESC and jumper 1 on

I think it is really a poor design  no instruction came with the board and all you have is the blogs and wikki which are in fact very confusing   can anyone confirm having had the same  blow up board ????

Using APM 1.1.9 does show the board up again, but updating firmware still gives, "Cannot detect the version of APM" error, trying to connect it would result in "no HEATBEAT Packets recieved" error and going to termnal will show the board is connected, serial com port opened, clicking on "linkstat" in Terminal shows  packets=0, quality = NaN. Same LED behavior. I cannot send commands via Terminal.

That's an ancient version of the software using an earlier version of MAVLink. You won't be able to connect to the current MP with that. 

I think you may have broken hardware. 

so i tried 1.1.2 again, the board shows up, but still cannot connect or update firmware, the Rx and c lights blink when I try to update the firmware but it still gives the same error. If there is nothing else I can try I would want to send it in for repair.

Widows treats each physical USB port as a separate device. Try another com port that has not been used to plug the APM in and see if the drivers install again and it shows up.

There are other tricks to get windows to reset the driver assigned to USB devices, but they all in essence do the same thing in they rewrite the registry entry, which can be done manually using RegEdit.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service