I just finished building a DJI F450 with APM 2.6. All the calibrations went fine until i got to the radio calibration. It shows no stick movement like the rx isn't sending signal to the APM? I checked and double checked the connections, I even took the rx out and put it in my plane seemed to work fine. Also a link to the rx to apm channel connections would be helpful. I hope someone else has had the problem and fixed it.

           Thanks, Doug

Views: 518

Reply to This

Replies to This Discussion

Hi Doug,

I don't use 9xr but Turnigy 9x and used to have similar problem until I almost gave up. All I did was de-construct all the electronics and re-construct again (with new cable) and voila! It worked well. I found some explanation from this guy:

http://www.youtube.com/watch?v=iUahfiWcSfY and from a guy called Dennis Baldwin also in youtube are really useful. Dennis has a really clear video as well so that you know exactly how he does the cabling.

By the way, no stick movement for both sticks (left and right) or only one of the sticks? Might be a Tx board/connection/solder issue?

Best wishes and good luck Doug,


Hi again Doug,

Here is an example of Dennis' tutorial : http://www.youtube.com/watch?v=E1a08Osy7HY I found all his videos are really useful easy to follow and clear.

Good luck Doug,


Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service