Hi,

I've done lots of thread-searching but haven't found a fix; any help would be appreciated.

I am in the process of upgrading from APM 2.5 to APM 2.8. My problem is that I cannot get the GPS / Compass to work. It is (they are) a Ublox Neo module(s).

The MAG jumper next to the GPS connector is removed but even with it place I get 'Bad compass health' in Mission Planner.

I have plugged in two different GPS/Compass modules: one gives 'GPS: No GPS', the other 'GPS No fix'. I am unsure whether plugging them into the flight controller has friend them - the power LED's are unlit.

The compass connector has been pugged into the I²C connector and the connector below the GPS connector.

The connector is inserted like so:

 

I am sure I must have missed something obvious but I'll be blowed if I can work out what it is...

Thanks

Hugh

Views: 21091

Reply to This

Replies to This Discussion

You checked the external compass box on mission planner?

I'm having a slightly different problem with APM 2.8, Arducopter 3.2.1, and an external pole-mounted GPS/Ublox Compass module on a 155 hex.  Using Mission Planner I am unable to get this external compass to calibrate. 

The jumper has been removed (which SHOULD disable any on-board compass), APM 2.5 is selected as the F.C. type (there isn't a selection choice for APM 2.8), and the external compass is selected as the compass to use (all on the Compass Calibration screen).  I can hit all the white dots on the 3D display that you see when you aim the front, right side, back, left side, bottom, and top at magnetic north and rotate around the L-R axis (like the YouTube video shows). and I can get a fairly well spread out pattern of "hits" showing on the 3D display.  However, when I click on "done" MP immediately pops up a window in which it says "Compass Calibration failed!"

I've tried allowing MP to automatically extinguish the white dots as I hit them, and I've tried doing it by disabling that feature and hitting them manually by myself.  The first method usually times out before I have hit all the white dots, but the second doesn't have a timer associated with it, so I can take a little more time to get them all.

The sad thing is I DID get the compass to calibrate about a week ago, but now it won't (no changes have been made to any hardware since then).  The only thing different is that I went into the firmware and changed the MOT_SPIN_ARM value from "70" to "0" (to stop the motors from automatically spinning upon arming the copter).  For some reason that change never got from the Mission Planner screen to the FC EEPROM when I hit the "write params" button (what DID happen was the copter no longer arms properly (the red light on the APM turns solid red, but only for a second - then it goes back to flashing) and the motors don't respond to throttle inputs. 

I've re-uploaded the firmware that I was using last week to the EEPROM, but I still get the same results.

You can call me "Frustrated and Confused!"


Update #1

Today I tried doing a compass calibration by selecting the option to have the FC automatically learn the compass offsets, selecting my external-mounted compass as the one to calibrate, and then clicking the "Start" button in the window labeled "Onboard Compass".  I then aimed axis towards the earth (as described in a wiki that I had come across), one after the other.  It appeared to me that nothing was happening, so, after a couple of minutes, I clicked on the "Accept" button.  

Up popped a message window which announced that the calibration had passed!  

I then switched over to "Flight Data" and saw the GPS was still showing true north to be about 30 degrees to the left of where it should be.  Getting even more frustrated, I unplugged the USB from my computer, then plugged it back in again.  Viola!  The GPS showed true north as being right where it should be!  

I thought "Great! THAT problem is now fixed!"

I thought wrong.  As I sat there looking at the HUD I noticed the bearing readout down below was slowly counting upward about 1 degree every 7 or 8 seconds.  It did this at a steady rate until it had moved the map display one direction about 10 or 12 degrees.  At that point it started counting downward at the same rate until it had gone back past true north about 10 or 12 degrees, where it would reverse and go back to 10 or 12 degrees on the other side of true north. It never stopped doing this (but it DID stop showing any movement on the HUD when I physically moved the copter!)

Again, "Frustrated and Confused!"


Have you been able to solve the problem of your APM not being able to show "north" where it should be?  I'm having lots of problems with that, too:

1. My hex is configured as an "X" frame.  The flight controller's "forward" arrow points to a spot exactly in the middle of an imaginary line if you drew one between motors 3 and 5 (the two front motors).  Using an inclinometer that measures in individual degrees, I leveled the flight controller "dead on" before I calibrated the accelerometers, the compass, and the radio, and I made sure AHRS_ORIENTATION has a value of zero (no rotation of any amount on the roll, yaw, and pitch axis).  

When the GPS is showing the copter is pointing to true north, the flight controller's "arrow", as well as the one on the GPS module, is pointing about 30 degrees towards the northwest from what it should be.  I've been working to fix this for days and days, but no luck so far.

2.  With AHRS_ORIENTATION value set to zero, east and west get transposed (i.e., when the nose of the copter is pointing east, the HUD shows it as pointing west).  North and south are where they should be.  If I change the AHRS_ORIENTATION to value 8 (Roll_180), the HUD then shows east and west in their proper places.  But, I think I would find it rather disconcerting to try to fly anywhere with the ground showing on top and the sky showing on the bottom in the HUD.   

Things might work out okay if I flipped both the roll and the pitch axis 180 degrees, but that isn't one of the options given in AHRS_ORIENTATIONIs available choices.

A little help here would be greatly appreciated..

My set-up

Frame:      Flamewheel 550 Hex                

F.C.           APM 2.8

Firmware: A.C. 3.2.1 

Motors     Turnigy Prop-drive-28 1200 KvA Brushless      

Props       9" Nylon

ESC         Turnigy Plush 30A 

TX / RX    Turnigy 9x / Turnigy 9XBC V2                        

GPS         3DR                         

Compass: Ublox Neo 6-NM on a 6" pole

Battery:     Turnigy 5000 mAH 30-40C 4S Li-Po

PDB         3DR          

 

 

 

 

Ron Waclawik said:

I too, am at my wits' end with trying to eliminate the BAD COMPASS HEALTH warning on a brand new 2.8. There is very little posted on You Tube that solves the issue. There is a post that pointed out a new jumper on the 2.8 board, next to the GPS port. The poster stated that removing the jumper disabled the on board compass. I found BAD COMPASS HEALTH with jumper in or out, and could not get north to be north on my Apm. I've about had it. I had the same issues with a 2.6 board, that never has flown either. I did the jumper severing thing... nothing helped the Compass situation.

Ron, AFAIK there is no compass on a 2.8 board.  I have a 2.8 board and have tried calibrating an "onboard" compass, with and without the jumper being installed, and I get the same result - no compass.  I can, however, calibrate an external, pole-mounted compass - but only without the jumper being in place. 


Found this:

If you have a 2.8 with external compass do not use the 12c, plug it into the plug under the GPS plug and you have to remove the jumper to the right of the GPS.

See: http://discuss.ardupilot.org/t/apm-2-8-compass-calibration-error-99...

It works!!

Thanks to those who know...

Best DP

I do have a 2.8 and an external compass.  I don't have any installation instructions with it, though, so I did my best when I initially installed the GPS/Compass unit.

Here is the GPS/Compass wiring layout (as best I can describe it):

Coming out of the GPS/Compass are two separate wire "bundles" - one consisting of only two wires, blue and white.  The other bundle consts of four wires - red, yellow, green, and black.  

The first bundle (blue and white) terminates in a 4-position female connector, and occupy the two inner pins of that connector.  This connector was attached to the 12c connector of the APM (a 4-pin male receptacle) when I was experiencing that which I previously wrote about.   Your suggestion to insert this two-wire bundle into the connector "under the GPS plug" would be fine except on my unit that receptacle has six male pins in it

The 4-wire bundle is connected to a 4-pin female plug which, in turn, is plugged into the 4-pin male receptacle that is just inboard of the GPS plug receptacle.  Looking down from above, and with the "forward" arrow on the APM pointing straight away from me, the wire colors are (starting at the pin furthermost away from me), red, yellow, green, and black. 

 Have I perchance gotten these wire bundles plugged into the wrong receptacles?  (I am not currently set up to experiment on this due to health issues so that is why I am asking this on the forum.  Also, I do not know if switching bundles around different receptacles and then powering up the APM might damage something in those components.)

Hi Hugh,

Happy to hear that you could solve it. I have the very same issue. Connected everything as expected, but at the beginning got no signals. Even the lights within the GPS-Compass do not blink, or turn on whatsoever.

Could you please tell us, in a few lines, the details of the procedure you followed to have it working?

I think many people, of course including myself, will be very grateful! :)

Best Regards,

Leo


Hugh said:

Thanks All,

I tried Nicks suggestion of tweaking the Ublox software and APM21 - no change. It started working when I moved everything back to the APM 2.5 board, did the same update and then moved things back to the APM 2.8 board. 

Thanks again, I got there in the end.

- Hugh

Hugh,

What APM board were you using when you originally noted that the Ublox was not working properly?  Had you already updated the Ublox software at that time, or did you update it later?

I take it that your setup works (i.e., the updated Ublox) works with APM 2.5, but not with APM 2.8.  Is that correct?


Leo said:

Hi Hugh,

Happy to hear that you could solve it. I have the very same issue. Connected everything as expected, but at the beginning got no signals. Even the lights within the GPS-Compass do not blink, or turn on whatsoever.

Could you please tell us, in a few lines, the details of the procedure you followed to have it working?

I think many people, of course including myself, will be very grateful! :)

Best Regards,

Leo


Hugh said:

Thanks All,

I tried Nicks suggestion of tweaking the Ublox software and APM21 - no change. It started working when I moved everything back to the APM 2.5 board, did the same update and then moved things back to the APM 2.8 board. 

Thanks again, I got there in the end.

- Hugh

Teach us more in this field. After reading on here, we can learn more in this topic.

Easy fix, just reinstall firmware and Bad Compass Health will be fixed. Do it every time that is displayed.

Ron Waclawik said:

I too, am at my wits' end with trying to eliminate the BAD COMPASS HEALTH warning on a brand new 2.8. There is very little posted on You Tube that solves the issue. There is a post that pointed out a new jumper on the 2.8 board, next to the GPS port. The poster stated that removing the jumper disabled the on board compass. I found BAD COMPASS HEALTH with jumper in or out, and could not get north to be north on my Apm. I've about had it. I had the same issues with a 2.6 board, that never has flown either. I did the jumper severing thing... nothing helped the Compass situation.
I had the same situation.(is your copter spining at mission planner?) So what I did was I didn't use the compass on the GPS. Just put the jumpers back just like the first time you got it, and don't plug in the compass on the APM 2.8. This worked for my APM 2.8. This could help your situation.

Ron Waclawik said:
I too, am at my wits' end with trying to eliminate the BAD COMPASS HEALTH warning on a brand new 2.8. There is very little posted on You Tube that solves the issue. There is a post that pointed out a new jumper on the 2.8 board, next to the GPS port. The poster stated that removing the jumper disabled the on board compass. I found BAD COMPASS HEALTH with jumper in or out, and could not get north to be north on my Apm. I've about had it. I had the same issues with a 2.6 board, that never has flown either. I did the jumper severing thing... nothing helped the Compass situation.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service