Hi everybody,

I've ordered an APM2 at the begining of dexember an tody is D day ! I've just received my board but it's starting by a big deception (I hope i'm wrong).

I've just connected the board to my pc USB an NOTHING happened ...

Windows, doesn't detect any device ! I tried to change USB port but nothing.

Do I need to power the board with anything else that USB port ? Does it need me power to be detected ?

The board are supposed to be tested so I can imagine that i's working ...

Please help.

Views: 1366

Reply to This

Replies to This Discussion

Did you load the FTDI drivers?

Are there any lights on the APM2 when you plug in the USB?

If not, do you have another USB port or computer you can try?


Hi Mike, thanks for helping me.

There is no light on the board. I can't install driver for the moment because the board is not visible in the Device manager.

I already tried another USB port but not the cable. I don't have another one.

It sounds like your USB is not giving power to the board. Look at the diagrams at http://code.google.com/p/ardupilot-mega/wiki/LED for the LED meanings. You should see the "ON"/Power LED. 

Do you have another USB power source? Perhaps a wall plug or car plug that uses USB ports? 

No for the moment no led, I'll buy a wall plug to test this.

Like an iPhone/iPod charger? You maybe already have something. USB is +5v, many USB chargers will work. Some might not be powerful enough to power the APM and attach things also, so unless you know the electronics, don't add anything except the APM itself (no RX, no servos, etc)

Also, do you have any jumpers on the board? jp1, jp2, etc?

no, no jumper on the board.

Do you have an ESC and a lipo? If so, connect them to the APM on the servo rail as shown in the wiki, and watch to see if the green power LED lights up. 

Unless you have the green power LED, nothing will happen with the board. Maybe there is no power, or maybe there is a problem with the board, it is hard to know unless you have a multimeter and know some basic electronics...

Or that is my understanding, I don't have an APM2 yet *wink*



Also i suggest you to post your issue here



and ask for help from somebody who do own APM2 board....

OK great news, I bought a new USB cable and the board started. Leds are blinking like a christmas tree :-)

Thanks !

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service