Hello,

We have a quadcopter we've built using Emlid's Edge flight controller. Everything is well calibrated (according to QGroundControl) and looks fine. Whenever we attempt to takeoff, the drone flips over on its side pretty much instantly. It is a fairly large quadcopter (550mm frame).

I've attached logs below as we are pretty new to this and I'm sure people on here know more about how to diagnose the problem than we do. Any help to diagnose why this is happening would be helpful.

Whatever other information I should've provided please let me know.

Here is the copter:

Kind regards!

Views: 92

Attachments:

Reply to This

Replies to This Discussion

Hello,

Try to share your .bin file (downloaded from Edge). From first look at the .log file parameters, you use default parameters.

Can you share a picture of your quadcopter (from above) and confirm Prop size and take-off weight.

Best place to discuss is Emlid forum (Edge specific problems) or Ardupilot forum. https://discuss.ardupilot.org

Marc

Marc,

Thanks for the reply. Attached is the .bin, and below is an image of the copter. The props are 12x4.5'', however the grey ones are slightly stiffer than the black ones. Could this cause a problem?

I've made a post on the Arducopter forums, but I've refrained from doing so on the Emlid forums as I am not certain this is an issue with their flight controller... I'm more convinced the problem is between the seat and the steering wheel if you know what I mean :)

I don't have an accurate scale but I'd estimate the takeoff weight is between 1.5-3kg. Not much on there aside from the battery, FC+GPS, PDB, and ESCs.

Attachments:

There is something. In the Edge RC settings, RC2 (Pitch) is reversed. It should not. You have to reverse the Pitch channel of your RC Tx. You will have to redo the RC Calibration after changing your RC Tx settings.

  • RC1_MIN
    985
  • RC1_TRIM
    1501
  • RC1_MAX
    2009
  • RC1_REVERSED
    0
  • RC1_DZ
    20
  • RC2_MIN
    987
  • RC2_TRIM
    1498
  • RC2_MAX
    2009
  • RC2_REVERSED
    1
  • RC2_DZ
    20
  • RC3_MIN
    985
  • RC3_TRIM
    985
  • RC3_MAX
    2008
  • RC3_REVERSED
    0
  • RC3_DZ
    30
  • RC4_MIN
    987
  • RC4_TRIM
    1496
  • RC4_MAX
    2009
  • RC4_REVERSED
    0
  • RC4_DZ
    20

There is another problem: Your RC failsafe value setting is at 985. It is also the RC3 Min value (from RC calibration). RC failsafe  could be set at 950 (if necessary, cheat with the rc3 tx trim to program the receiver failsafe). As you have to play with the RC Tx settings, adjust your RC1 to 4 endpoints  in order to be in the 1000 (1010-1050) -- 2000 (1950-1990) range instead of 985--2010. 

Before applying full take-off power, adjust enough power (in stabilise mode) and nudge roll and tilt commands to check if the copter motors follow your orders. If you are happy with the reaction, increase power until it is flying.

Marc

Thanks a ton for investigating. It's appreciated. I will try this and report back.

What would cause that parameter to be reversed? I've never changed that manually.

Looks like we had a motor that wasn't performing consistently. Sometimes it would work as expected (during calibration!) but in the real world it wouldn't always work. We've got replacement motors coming and will try again then.

Hello,

Parameter reversed: could be part of QGroundControl radio calibration process. 

Motor problem: It also could be a bad ESC calibration. You can redo ESC Calibration with a receiver and a 4 in 1 plug or repeat the process for each ESC. 

Marc

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service