Good day guys, hope you can shed some light on this..


 I think I blew the outputs of my APM. The mux led doesn't light up when I power it up through the the rc's ubec  and it doesn't receive my rc input and the leds aren't that bright.  However, if I connect the usb to the IMU, it suddenly started initiating the arducopter code and started to receive rc input. But when I remove the usb, poof, its a colorful paper weight again :))The mux led lights up when I connect the usb. It can still detect rc input when using the CLI.(without being powered by the ubec from the rc)


  If my memory serves me correctly, I accidentally pulled the rc battery off while the apm is still connected to the usb :( So I guess that did it :(


  Before, we tried loading the apm 1.02 code to test the sensors and its connectivity to hk's gcs and it worked, but after the 'accident', the apm doesn't seem to initiate the code although the power led is on.


   So right now I'm sort of troubled because my groupmates would probably hunt my ass for this haha! Can I just replace an IC that was 'fried'?  (I'm hoping I won't need to buy a new apm as my groupmates won't chip in since I wrecked it)


  I tried separating the power from the rc(I desoldered the sj1 jumper and provided an external 5v) but the problem still persists:(


  The IMU seems ok, its ftdi is still working along with the other sensors.



Views: 279

Reply to This

Replies to This Discussion


> If my memory serves me correctly, I accidentally pulled the rc battery off while the apm is still connected to the usb :( So I guess that did it :(

That shouldn't be the reason, as I do that all the time...

In my opinion, you are underpowering your APM. If you use the external supply 5V is not enough, because the voltage regulator needs a higher voltage to be able to supply 5V. Use a 2S Lipo as an external source (at least 7V). Once, I supplied also 5V there, and had a similar behaviour as you have (multiplexer was not working correctly).

Which APM are you using? V1.0 or v1.4, 1.0 has numbers 0-7 and 1.4 has numbers 1-8 on the servo connections.


When I wanted to power my APM with 5v I shorted out the onboard regulator and it seesm to work very well.


READ THIS before you do what Andrés suggested:

APM needs 5V, nothing else!

on the old version (1.0), there is an onboard voltage regulator, which can be used with more than 7V (but it has other input pins)


test your ubec, maybe it's damaged


Hi Sebastian,

> I desoldered the sj1 jumper and provided an external 5v

This sentence suggests that he meant an external battery at the corresponding pins. If you supply less than 7v there, you get exactly what he was reporting. I did not want to encourage to feed the APM with 7v at the rc-input pins...

The new boards do not have a voltage regulator? The wiki does not state any change about that ( and in my opinion this wouldn't be an improvement...


the new board has a voltage regulator, but it is too small for the complete APM

Thanks for the feedback guys!=D




Hmm Ok I'll try to power the apm then with a 2s lipo on the corresponding pins.



Ok I'll also check my ubec as well



Its v1.0

I've nearly the same problem..


I've a APM v1.4 and when i plug my 5V BEC, nothing happends. The APM doesn't boot or work. But when i plug it with usb, all works nice...

I've checked the BEC voltage with a multimeter : 5,0 V as expected..

So what's wrong with my APM and is it the same problem as Jonathan ??



I am having the same problem.  Using the 2560 board.  Everything works just fine when on USB, but I get only the solid yellow MUX light and red pwr light when on battery power.  Nothing on the shield lights up at all.


Checked over all the solder points, all looks good.  The ESC is working fine, as it properly powers my second APM (which is working fine).


Anyone have an idea?

hmm try separating the power source of the apm, by shorting SJ1 at the apm and put in a different power source there.. that's what we did and it worked

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service