APM connection failure (new install) COM port does not exist --solved--workaround


I guess we can put this one to bed. I went to my office and got a windows 7 laptop and the problem doesn't exist with Windows 7.  I tried another XP computer and had the same problem, it wouldn't load the driver and locked up until I pull the usb cable. The initial XP computer I was using was a virtual machine running on MAC Parallels.   I had thought maybe that was the problem, but apparently it is a Windows XP problem

Then I tried a Windows 7 physical machine and it worked fine. Then I tried a Windows 7 virtual Machine running on Parallels on a MAC and that worked just as well, loaded faster actually.

So I brought my Macbook Pro home with Windows 7 on it and I am good to go.  

uploaded the latest available firmware and now proceeding to assemble the legs, mount and connect the receiver, and will be setting that up by this afternoon.



Can anybody help.. I seem to be stopped at step one when trying to configure my new copter!

I just got my ArduCopter (pre assembled) yesterday, so now I am taking the first steps to configure it.

I have a MAC, but use Parallels to run XP for windows programs (This works fine on setting up my FW-450.  I installed the software "MissionPlanner-1.2.27msi.

The instructions in the manual say to install "APMPlanner(version).msi, but I don't see that in downloads, so I figure that the one I installed is with a newer name but the equivelent. 

During the install it says that it has installed two drivers, they both mention usbser, one is for 3DR, and I forget the other.  Then I plug in the USB from the APM and I get the pop up that says "found new hardware "Arduino Mega 2560".  (the APM lights up red and blue)  That message stays on the screen and never gets to the phase of installing a driver or saying the hardware is ready to use.

If I try to connect from the mission planner it tells me there is no such com port (4).

In the control panel, system. device manager, ports, I see the Aurduino Mega 2650 with no com port assignment, and in status, it says "no driver installed" there is also no "Port settings" tab.

If I unplug the USB, then I get an error saying "Found new hardware: there was problem installing your hardware blah blah blah" (I couldn't capture the exact error message because as soon as I clicked it, went away.

After unplugging it and getting that error though, then the com port 4 shows up in the driver description in the device manager ports for the Arduino. however the status still says no driver installed, and the mission planner still says the com port does not exist. etc. I have unistalled the ports in the device manager several times, and started over, there were other serial port devices from some wireless modems I used to use, and deleted all those and rebooted, I have been reinstalling the drivers, the software and rebooting for hours and the results have been the same every time.

Another odd thing is that in the device manager, there is not tab for com port settings. only tabs are "general, dirvers, details" 

anybody have a suggestion of something to try? 




Views: 10647

Reply to This

Replies to This Discussion

I had this same problem.  I got it fixed by downloading the drivers for the APM 2.5 board from the downloads section using IE.  I tried firefox but firefox turned the drivers into txt files and the device manager couldn't use them.  Download them to the desktop so they are easy to find.  Also you need to download the .NET framework 3.5 from here  .NET Framework 3.5 SP1  3.5 is the only one that will work with my version of XP so I would suggest you start there.  Once you have the driver     Arduino MEGA 2560.inf     you need to go to device manager then right click on the APM board and click "update driver" then search for the driver where ever you downloaded it to.  Don't do automatic because it won't find it.  Once your updating the driver it would hang at some point in the update, just unplug the APM board and it will finish the driver install.  Then you will need to restart the computer.   I went through alot of trial and error downloading over and over and trying different things so there may be a missed step in there but thats the basic gist of it. It came down to needing .NET Framework 3.5 and to manually install the APM driver.  

Hi Josh, Thanks for your suggestions, I appreciate your trying to help. In approximately 8 hours of continuous effort to solve this, I did all of those things, and ended up reinstalling the driver many many ties, rebooting, and learned a lot about how stubborn the problem could be. I don't even want to go back there now, I am using windows 7 and it works fine. however, I will revisit this in a few days and try once again.  IT would be nice to use my main laptop and to have to haul around a special one to do the Mission Planner.  

Thanks again!

Better solution..... get it to work on a mac!!!  No problem good luck, glad you got it working on 7

Hi Josh,

many thanks, received my APM 2.5 yesterday and had the identical problem,

I can confirm it is an XP issue and the update of the provided link to Arduino MEGA 2560.inf driver fixes it.

What I did:

- installed MP & connected APM to an XP (SP3) with VMplayer 4.04 => failed

- installed MP & connected APM to Win7 => worked, and uploaded firmware, connected all good.

- reconnected APM to XP on VMplayer => still doesn't work

- installed MP & connected APM on XP (SP3) on a native machine => same issue

=> upgraded driver on XP on the native machine => all good

=> upgraded driver on XP on VMplayer => connects but looses some packages; but <b>starts</b> communicating

(will do some more tests and let you know; recompile fw with lower connection, faster host for vmplayer)

The com ports can get jammed up some times.  Maybe try the solution in this thread:


Thanks...   Problem solved!

I had already tried most of the procedures mentioned in these threads, but it inspired me to try again and do everything over again. The only thing I hadn't already thought of was the displaying hidden devices, this gave me hope there was something there that would let me fix it. Well, actually there were no ports showing up there other than the Mega 2560 driver, be I went ahead and uninstalled it, rebooted and still had the same results as before, the driver would just hang at the point of copying itself to usbser.sys in the Windows/system32/drivers directory. Unplugging the USB cable would unhang it and it would report successful but the status under the device manager still said "no driver" installed. So I went back the the downloads directory to download the mega2560.inf file again, I deleted usbser.sys , and any previous mega250.inf files and put the newly downloaded one in the driver directory for the MP software and then plugged the USB cable one more time. I allowed it to attempt to install mega2560.inf and as before, it came up with "driver not installed", I right clicked and said update driver, chose have disk, and navigated to the driver directly and chose the new mega560.inf and chose to load it. I then got a box showing two mega2560 drivers, one signed, and one unsigned. the first time i chose the signed one. it didn't work same results as always. 

I went through the drill again and then chose the unsigned one, and rebooted, came back up, went to the device manager, check to see if the driver was installed and Eureka!

It was there.  so I launched MP, set the correct port and it worked....   Finally!!

thanks for all the help and that one is behind me.


Note # this solution seems to be using the unsigned driver version, I assume it is the one added separately in the downloads area, rather than the one bundled in the MP. Something that is still goofy is that the driver installation, even when it worked finally still hung during the process of installing and I had to unplug the USB cable and upon rebooting it was fully installed. this might frustrate a user because it is counter intuitive.  Anyway I am very pleased that I don't have to drag  my windows 7 computer around to get to the CLI

Glad you got that working! Well done on the detective work.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service