APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99907

Reply to This

Replies to This Discussion

Ok.

Hmmm... I just took a look at the news on mikrocopter.de, they now offer an external acc board for better alt hold. They use a 3 axis R9500 mems sensor, which is working on the basis of thermal changes and promises not to be affected that much by vibrations like "normal" acc sensors.
Could this be implemented as external acc sensor on the apm?
Regards
Marc

Yea, I'm aware of WP_YAW_BEHAVIOUR which worked fine for me as long as the RTL was not triggered close (a few meters) from home.

In any case, I was seeing a significant magnetic interference in the logs so I shuffled components abit and will try again.

Also, I switched the cc3d out of my microquad for a px4 running -dev branch and see how the code runs there. Daily commits are fun, thanks devs ;)

I pray every volunteer testers to leave your feedback about the version 3.0.0.rc1 available only for expert users on GitHub (downloadable here), you can interact and leaving your comments in this discussion but of course, first update your APM, calibrate manually the compass and declination, try it and post your impression!
Remember: there's safety system on V3, you can't arm the motors if you compass or accelerometers value are wrong or out of range!

In the first post there's my parameters.

Thanks, Marco

Marco,   I assume it does not stop motors in the flight anymore?  Just do not want to sacrifice all booms and props again on the FPV Y6.

Marco, github should only be used for tracking issues. Let's keep the feedback about performance in the copter testers group. Problems can be discussed in the testing group and and real issues added to the list.
Otherwise people could easily innundate github with comments and then it becomes useless to us as an issue tracker.
Thanks.

Yes Craig, thanks for the advice, I'm trying to recruit some experienced users for refresh the testers group because the current ones are testing too little, and then when you release the problems are always too many.
I specifically asked to report any problems on the discussion list, not on GitHub.

Ops, re-reading what I wrote I just expressed myself badly, I did not mean I would say to put comments on GitHub, sorry, now stand corrected!

No worries. Thanks for all your great work Marco!!

When will the V3 be out for the likes of me please,your's Marty.

thank you to the developers

Hi,

I uploaded 2.9.1.b, but I have some problem with my hexa. Stabilized mode is very smooth, but loiter is very wobblish. I tried to tune the params, but without success. Bigger problem when I switched to RTL and the hexa approached the starting point it tilt to the right and went away. I had to switch back to stabilize to save my hexa.  

Here is my log file maybe somebody can help me what is wrong. 

Thanks

Attachments:

Hello all,

after upgrading my firmware from 2.8.1 to 2.9.1b on my APM1 , the  altitude_hold does not work any more. I am using the XL-MaxSonar EZ0. I want only to fly near the ground with a maximum height of 3m. In 2.8.1 firmware I was able to achieve this very precisely (error ~ 5cm). Now with the new 2.9.1b firmware the ArduCopter altitude_hold is not precise any more. for example when i hold ArduCopter 1 meter above the ground, the altitude value in Mission Planner is jumping over the time. Even after disabling the sonar the height measurement is still worse than in older version of firmware. I found it more practical to keep the sonar for low level altitude_hold (4 meter) while using the pressure sensor for higher level.

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service