APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99894

Reply to This

Replies to This Discussion

Good to hear you got that sorted, but the more I read about sonar the happier I am with my decision to abstain. :P

But just the sonar and the Optflow are important features, with for example, Mikrokopter has not.

Very nice and stable flight, I am glad you have this performance with MediaTek GPS.

Could you please post your param you are using? And which version of Arducopter?

Dave C

I just follow your detail instruction on "drones discuss" that 

Put ch6 in the middle, put it in loiter, fly forward and then back, repeat. Is the heli drifting off to your left or right? Adjust channel 6 a bit in the opposite direction and try again.

It is too scary procedure for ordinary pilot, like me:-)

On the loiter, copter is going very high speed that is out of my expectation.

Please consider much moderate method.

The crash of unknown cause.
After 3 minutes flying it cut power suddenly on all engines. The hexa flips around and fall to the ground upside down.
I've attached logs and video. Lipo detector beeps for approx. 1 min. and flips machine after 3 min. in the video. The Gopro3 is placed on side of landing gear facing to the right.

S800 with APM 2.5 and 2.91b
2 x 6S 8000mAh in parallel.
Batteries measured 23.8 volts after the crash, realize that lipo detector beeps during takeoff with large power consumption, by this time it alerts no more.

Have checked the logs and can not find similarities with the video. Need some help here.

The injury was a broken arm, carbon tube on the landing gear and four props.

Here are the log files...

Attachments:

What about apm power supply? I looked at logs all looking good. Seems like APM lost power (logs stops suddenly).

That my IMHO. Maybe some people have another opinion.

Thats when it cut the motors suddenly. APM powered by 90Ah Atto current sensor to sensor rail on APM.

Hello,

My question just why Crash?

I Fly 2x Times high, after this slowly fly down and switch to ROTH ( Lose Video Signal) but the Ardupilot don't give throttle...

 This is the Second Crash in RTH Mode! Many Times i test the RTH Mode and it works!

But always if i need this function, it doesn't works!

Attachments:

I've been testing version V3.0.0-rc1 and quite pleased so far. However, I did find a rare but nasty bug which causes the copter to tear off to the southwest at high velocity and fast decent rate until it crashes into the ground or you switch back to manual mode. It is triggered by having two successive waypoints that are the same, for example if you mistakenly put two waypoints in the same place in Mission Planner, or if FollowMe sends two successive waypoints that are the same location.

I think perhaps the offending code is line #250 of AC_WPNav.cpp:

_pos_delta_unit = pos_delta/_track_length;

I think this would be a division by zero if successive waypoints are the same, and that could be what's causing the out of control flying southwest into the ground. In the logs, right where the copter goes crazy, you also start seeing a lot of nan's.

Hopefully this should be an easy fix in the code.

Hi.

With respect to the APM power module, analyzed this module, it is likely that current peaks of different frequencies from plaque distribution (ESC's) are affecting the sensors of APM, in my opinion, I think the engineers "Mikrokopter" (http://www.mikrokopter.de/ucwiki/en/FlightCtrl_ME_2_1) resolved these problems adding a filter stage before and after the regulator IC 7805 (IC3 and IC4), then fixed capacitor values ​​using (1 of 330microF and 6 of 10microF), including the feeding of the servos do through a second IC 7805. I'll do the same for my APM2.5, I do not believe that a "UBEC" type regulator "Switching" commercial resolve this problem.

...

Rafael Villegas

Valencia-Venezuela

Hi Walthero.

The same thing happened to me once at 2 meters. In my logs, the APM is left without feeding (was shut down) and then I realized analyzing the feeding gimbal servos were connected to the same feed of APM when running the servos consume more, they add interference to food and can dangerously lower AMP 5V. You have to separate the Supply of APM (+5 V) of the Supply of Servo. 

Stage Afrega filtering stage regulation using "Mikrokopter"(http://www.mikrokopter.de/ucwiki/en/FlightCtrl_ME_2_1),Watch the diode "D2" Mikrokopter circuit. Incredibly engines can change the polarity of the batteries in a matter of milliseconds and this is enough to turn the APM, you can make your alarm has sounded Lipos for this cause.

 And ready.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service