APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99894

Reply to This

Replies to This Discussion

Can somebody know why the APM take so long to initialize since a few builds. My DJI 30a ESC are beeping for 1 minutes before the little music. Before it was like just 1 beep before the "OK sound".

I am very keen to go back to 2.8.1 until a stable release of v3 is available, but there is an error downloading the file from the servers, see http://diydrones.com/forum/topics/how-to-go-back-to-a-different-ard...

Any chance that can be fixed as I really do need a stable loiter for some work I am doing at the moment and 2.9.1b is just not good enough!

What version of MP and what error are you seeing trying to download?

2.9.1b will hold station within 20cm vertically and 1m horizontally.  How much better do you need?

1.2.48 see the link I posted it goes to the thread about it http://diydrones.com/forum/topics/how-to-go-back-to-a-different-ard....

The station keeping isn't the issue, its the wobbling that is not useful. The camera gimbal just can't keep up with it. Since 2.9 changed to inertial sensing the loiter became very fidgety (known issue and Randy suggested changes to help calm it down), but version 2.8.1 doesn't do that and has a very stable loiter, so filming is excellent, hence wanting to go back to 2.8.1 until the issue is resolved.

Hi Quentin, just as curiosity, which GPS are you using in your model?

I added a heavier camera to my quad. Now althold is compleatly messed up. it jumps up and down +-2m like a jojo motors behave frenettic throttle changes. No smooth throttle input changes to keep it in the correct alt.

where to start to make it give smoother throttle corrections?

it hower at 50%throttle. before it was 40% and then althold worked perfect after I added in higher IMAX and p0.5 i1.0 on the accel pid

Can some one please tell me what hdop stans for next to the sats number in mission planner please,thank you,Marty.

horizontal dilution of position. See http://en.wikipedia.org/wiki/Dilution_of_precision_(GPS)

Thank you very much Rick,Marty.

The mediatek that came attached to the APM 2.

I was able to go back to 2.8.1 from internet, see the version I did choose. When you seelct different item from drop down list, you will see on the label of each icon the revision associated. Just go down one by one and after a feww of 2.9.x, you will see an error, then 2.8.1. 

The reason I did go back to 2.8.1 is that same as you, my Loiter is unstable, although the ALtHold in 2.9.1b was such good. But I need this compromise, until 3.x will bring something new.
As I understood from other posts, the 2.9.1b is good, BUT with uBlox GPS. Someone did highlite they need to focus to have both MediaTek AND uBlox working at least as previous version. My MediaTek is firmware 1.9 and still unstable on Loiter (and Auto, RTL) with 2.9.1b.

What version of Mission Planner are you using for 2.8.1 ??

I asked before on this Forum what version of Mission Planner is best for 2.8.1 and did not get an answer.

I wonder at what point Mission Planner is only supporting 2.9 and higher.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service