APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99886

Reply to This

Replies to This Discussion

Terminal-> level

Terminal -> accel

Just a curiosity question about the loiter, having trimmed out the bad habits for this release the loiter is not bad at all, certainly acceptable for what I currently need it to do. However, when I am in a stable hover and then select loiter the quad starts to climb, if I leave it it will keep climbing, so why doesn't the autopilot correct that?

The only way I can stop it climbing is to reduce the throttle slightly then it is happy and stays put.

Quentin,

I guess this  is regarding to Roberto´s post?

Yes, strange why it appeared in you thread, definitely pressed the reply button on Robertos thread, weird!

Just tried it again and it did the same thing!

Roberto S, this is going into the wrong thread for some strange reason so had to put it as a new post!

There was discussions about that awhile ago, it is to do with the throttle trim setting I believe that the autopilot thinks it needs compared to the actual throttle setting for a hover (it is supposed to auto learn that setting depending on battery power available). It used to be called throttle trim, not sure what it is called now as I am not near my quad to check.

I had not thought ! I use this

http://www.youtube.com/watch?v=ayA0uYOqKX4

only for roll/pitch , i try with throttle

Thank you so much

Agreed, leave the crashing to the development and testing teams.

The beta releases should only been flown by experience APM users who are fully aware of the risks.

I for one love it when i have an unexplained crash (very rare these days) or strange behaviour in a candidate release because I know that when I present my results to the dev team any issues will be addressed and fixed.

Each one of mine or Marco's and others crashes/weirdness probably saves hundreds of problems for users.

For now 2.9.1 flies really well, and unless you want to use your airframe to help iron out bugs then I'd stick with the current MP release.

Yeah, I've had this too. I post videos with music, youtube bitches at me and disables the video for about an hour. Then the restrictions magically disappear and the vids become available.

Maybe it's due to my awful taste in music ;)

Yes RAW has be renamed IMU.

Try reinstalling MP using the msi. That usually fixes any probs I've had with it.

I think each of us using AC code and reading this forum should contribute to the QA process by flying and crashing at least once on each release.   I did it on 2.9.1 and 2.9.1b with full report on the forum.  I hope this helps developers.  Booms and props are cheap!

When it will be a good time to fly AC 3.x?  Is it now using RC1 or better make a clone from github?

Tnx!

It's probably best to wait for release candidates.  I am on the dev team, and I don't just go grab from trunk all willy-nilly.  I don't think users should either.

It is not a bug, it has worked exactly like that for many previous versions. It will not boot because Mission Planner does not detect the 3DRadio link is broken in part due to the fact Mission Planner only detects USB connection broken, but in this case even though Mavlink is disrupted the USB connection at the PC is still OK. It was not designed exactly for your 2 story house. I suspect it may have been designed for use with a laptop right next to you when you are flying :)

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service