APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.


Views: 99919

Reply to This

Replies to This Discussion

Hello Tridge,

build master with your fix. Now it runs perfectly! Tried today with 4-5 bft wind. Loiter is improved much over rc3. It now seems to 'lean' towards the winddirection. Stayed within 10 - 15 cm (!) with Ublox @ 1m above ground. This is best ever!

PID are all default and using a homemade quad (diam 85cm) with 880 motors on 4S.

My tuned params are much more aggressive, but didn't dare to test those.

Very good work dev team!



Finally got some time outside this weekend. Tried out RC4 on my lightweight quad - alt hold is VERY good. Loiter also very good - even in a breeze (this quad is kind of a kite usually). One thing I noted was that trying to reposition it in loiter was pretty close to impossible. As soon as I would move the quad, it would begin see-sawing - looked kind of like it was either a pendulem or balanced on a stick - hard to describe. But it was startling enough that I didn't push it. Is this expected behavior? Perhaps I need to tune something to get rid of this? With all the changes to Loiter, it may jsut be that repositioning in Loiter simply is no longer a valid option - which is fine - but I figure If I don't ask I won't know :)

But really, the overall performance was great. This cheap little beat up quad now flies like something WAY pricier.


First of all let me say thank you to all developers. Great job!

I am very new to multicopters and just finished a rctimer X650 frame with kit motors, 20A ESCs which I flashed to SimonK, APM2.5 and uBlox GPS. All sensors are calibrated including the funny dance. Flying 3.0rc4 I have the following issues and am wondering if you could point me in the right direction for changes.

1. In Stabilize the copter is quite agressive with slight overshoot upon releasing the stick in roll and pitch.

2. While hovering in Stabilize: when I control yaw input the motors spin up quite agressivly with the copter slightly gaining altitude. Yae rate is fine. Upon releasing the motors undershoot. I'd expect a much smoother transition from steady state to yawing and back.

3. ALT_HOLD is really good with nice manouverability but slow climb/descent rate

4. LOITER is really good with nice manouverability but slow climb/descent rate

5. RTL was scary. When switching from Stabilize to LOITER in a very moderate climb (close to hover) throttle was reduced very agressivly causing the copter to drop 3-5 feet. Then throttle cut in very hard. After that it stabilized altitude pretty good and returned to launch position. The speed on returning is high with a somewhat agressive stop manouver at launch position. Descent was good and straight with a steady LOITER a 6ft altitude.

6. I was wondering why the MODE log mode can not be enabled in the logs. I put it back in log.pde. Anything wrong with it? Only minor problem is that MP outputs mode as text (e.g. STABILIZE) rather than the corresponding number to the log file. Any idea of how to change this in MP?

Best Regards,




    1. hard to say but you might need to reduce the roll/pitch rate P from 0.15 to something lower like 0.12

    2. try reducing yaw rate P from 0.2 to something a bit lower like 0.15.  Setting the THR_MID a bit lower than the default (500) may reduce the climb on yaw.  You can see what your hover throttle is by looking at the CTUN message's Throttle In value while in stabilize mode.  Adjust THR_MID to be about the same.

    3. you can change the climb and descent rate by adjusting the PILOT_VELZ_MAX parameter.  it defaults to 2.5 m/s.

    4. same as above

    5. you can reduce the speed it returns to home at with WPNAV_SPEED parameter.  It defaults to 5m/s (500).

    6. we always print out the mode so no need to specifically enable it in the LOG_BITMASK anymore.  There's unfortunately not way to display the mode in the mission planner dataflash log.  We could extend the message so that it also prints the number corresponding to the mode though.  I've added an item to the issues list.

I run over some of this in this video:

Is it possible that the latest version of Mission Planner is not changing flight mode assignment properly? Just loaded RC4 onto one of my quads and took into the yard to try it out.

I changed my flight modes to:



Alt Hold




The last two had been AUTO and RTL. I saved the changes.

Flew it around and it was doing OK - alt hold was solid - though loiter totally sucked. Switched to Land to see how it handled that and the thing took off at very high speed straight into the roof of the house where all four props and motor mounts were destroyed before I could kill everything.

I quit out of MP and re-ran it and reconnected and the flight modes are showing as what I had them set for - with LAND as the last two modes.

I have no idea what happened, but it acts like the change was not written to the APM and when I hit LAND, it went into AUTO and tried to zoom off to a very far away way point. 

Here is the tlog. It shows me switch to LAND and then a beeline into the house. So the mode changed poperly - but for some reason, it decided to fly fast horizontally instead of landing. Just glad it was up a ways and not at head height. I will grab the dataflash log once I get the thing peeled apart.



Thank you very much for your quick response and adding an issue. It is exactly what you stated in the issue I am interested in.

I am going to try your adjustments.

5 is actually two issues:

5a. Throttle behaviour upon switching to RTL. It reduces throttle nearly to idle causing the copter to drop rapidly. Then applying nearly full throttle for a moment before stabilizing altitude, see current log at about 16 or 19.

5b. Copter speed on the return path. Speed is fast but actually quite good. The transition from forward flight to a standstill upon reaching the RTL position (before decent) is quite harsh.

Thanks again,





    You don't have a dataflash log do you?

     I'm afraid that the LAND issue is probably a real bug caused by me when I added support for landing at a specified location.  I found (and fixed) an issue yesterday in which when you switch to LAND mode it would check for if a lat/lon location was specified ... but this would mean it would go and check the lat/lon of the next mission command.  I checked with a person who had tested LAND to see if they'd noticed any weird behaviour but they hadn't.  We may need to rush out -rc5 with this fixed a little sooner than possible.

    I'm really sorry about this.


I will pull the dataflash later this evening - out running around right now. I guess you're fired :)

That sounds like it is probably what happened, though. 

Took a look at the map and the line it took was definitely in the direction of the flying field where I last flew a mission - unfortunately, about 12 miles away :)

Once you get your copter back together....I think you may need to reduce your loiter rate P.  Default is 1.0 I believe but there's a feed forward on the loiter controller now so you may need to tune it down a bit.  Perhaps 0.75?

Hi Randy,

Huh? on mine, loiter rate P default is 5.0! omg

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service