APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99885

Reply to This

Replies to This Discussion

Hey Randy,

Loaded the latest firmware 3rc5 on my tricopter. 

Noticing a toilet bowl effect when in loiter mode after may be 20 seconds or so into it and also after pitching forward. 

Uploaded the files for your analysis.  The first minute or so the compass live calibration was being performed.

Hope you can assess what's going on. 

Thanks!

Attachments:

ArduCopter V3 RC and "Loiter wobbling":

I want a confirmation from anyone who has tried the V3 Release Candidate version of ArduCopter, my quad has small shaky, a sorta of fast oscillations during the Loiter, it happens to someone else?
I noticed and reported this problem only from V3 onwards.
For the specs of my quad see the description of my video.

Thanks, Marco

Hello David,

taking a short look into your log files, there is a voltage drop (VCC 5V) in the area around 2375.

Can you try a big C in the 5V line? I think it would help.

I've got a problem regarding the log based geotagging with MissionPlanner. (RC5 and MP 1.2.53)

The log is always 4days + the real Photo date.

GPX Files do not contain a valid timestamp. The Day is right, but the time is 0:00:00.

It is impossible to tag Photos with the logs.

Could you please check it?

Thanks,

Yannick

Did you try to decrease loiter speed?

yes, have been pulling my hair out trying to make sense of this too and I am getting huge time offsets...

Hi,

I´ve  tested RC5 the last days and I´m absolute delighted. I had no tbe or oscillation on my (heavy- ca. 1.6kg) quad.

Good job team!

having a mag field of less than 330 is OK.  it apparently varies in different parts of the world.

the live offsets are high but not insane.

I think the problem may be with how the compassmot procedure was done.  is it possible that you took the props off?  the current draw seems very low.  ..or did you accidentally move the copter during the process?

Hi Marco,

I'm also running the 3.0rc5 since today (3.0rc3 before).
I'm having the same oscillations in Loiter moreover in althold I get pulsing motors.
I already reduced the Althold P from 2.0 to 0.9 but still no change.
Stabilize is flawless but as soon as inertial navigation is used it is bumpy.

Here is an extract of my logs from this evening.

The section in red is where I'm in althold and loiter, you can see that the throttle out is pulsing along the hoover value.
I also tried in reducing the Loiter P rate but this had no effect on the oscillations.


Regards

So I see ThrOut pulsing, but nothing like what you're seeing.... This from a recent flight on rc5:

What do your vibrations look like? This is what I'm getting:

I can't visibly see the airframe oscillating in the way Marco can.

Rick,

I must say that my AccZ is not as good as yours, mine is ranging from -5 to -15, leading to heavier pulsing behavior maybe.
What did you use as vibration dampening solution?
I used 4 blocks of Kyosho zeal tape on each corner of the APM2.5 housing and then some velcro between the zeal tape and the frame. I thought adding an extra material (velcro) will absorb some vibes in another freq. range.

Hello everybody!

Just uploaded rc5, made all the processes as mentioned, on my V-quad (TBS like)... Flying around in living room makes me feel pretty comfortable to fly outside, since my experience assures me that this will be ok. Still to go to "live calibration" for compass, just tell me again, since COMPASS_LEARN is now set to 0:

What is the most convenient way to make "live calibration"?

Should then auto-declination or so stay checked or no? 

I had no experience with this earlier... Tomorrow  I will provide the logs...

Tx&GoodLuck with the soon launch of AC3!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service