APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.


Views: 99961

Reply to This

Replies to This Discussion

Ok, thought I'd missed it somehow, was 99.9% sure I loaded quad :)) Thanks for your help and ideas anyway.

Thanks Marco I will try this...

Quiet around these parts!

Time for some appetite whetting.

Here's a quick video testing the next code with inertial nav working, there are a couple of little niggles for you to look at (all stuff that's being worked on pre-release), but also some very exciting performance. 

If you get bored, or sick of the shoddy camera work, skip to 5:12 for a full throttle blast on a monster, but put it in HD as the gopro and weather are awful

Oh and here's the trace of the 50 second loiter where the wind picks up from zero to about 15mph at 1:30 in the video, there are cars in shot for scale. Nice!

Looks like this next release is a winner.  You guys are awesome.  Anxiously awaiting the next release!

Just updated to MP 1.2.47 and i suddenly I got problems wit calibrating my accelerometer. When i hit the button "Calibrate Accel" I don't get the prompt to put machine on left side, right side, nose etc. but in stead I get a line with this text:
A-off:-0.35, 0.00, 0.00A_scale: 1.00, 1.99, 0.91
and the button says "Click when done". When I hit the button nothing happens.
I tried with another board and same thing.

Consider going back to earlier MP version.

Running 2.9.1b hexa firmware. Tried erase and reset as well.

That is something that we are working on. In the meantime you open up the console window in the help screen you can watch the messages there.

I'm still having my issue of the quad dropping in altitude when pitching forward and climbing when pitching back when in ALT_HOLD. (post) I've noticed that banking right also causes a climb and banking left a drop. But with the new version imminent it may not be worth pursuing this?

Is that with your folding quad?  It sounds like the center of gravity might be forward of the center of lift.

It is my folder, I've double-checked the CG - it's at 50% relative to the motors longitudinally and laterally. The log shows a noticeable throttle reduction when pitching forward, I thought I'd left a mixer on my Tx at first. Is it possible I did the accel calibration in the wrong order?

That might be worth checking.  See my note above about re-doing the cal.

I did it twice just in case, I do recall reading that Chris said it didn't matter in which order the calibration was done as all that was needed was 6 reference points? I can do it again if that's the problem but wanted to check with someone who has a better idea than I do.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service