APM Copter 2.9.1.b has been released to the Mission Planner and is also posted in the downloads area.
2.9.1b is a maintenance release incorporating changes to 4 default parameters that have been optimized since 2.9.1 was released.  There are also 4 minor bug fixes.  There are no code function changes or additional features.
 
The changes are:
1) reduce default INS_MPU6K_FILTER to 20hz
2) reduce InertialNav Z-axis time constant to 5 (was 7)
3) increased max InertialNav accel correction to 3 m/s (was 1m/s)
4) reduce yaw_rate P default to 0.20 (was 0.25)
5) bug fix for alt_hold being passed as int16_t to get_throttle_althold_with_slew which might have caused problems if you climbed over 320m.
6) bug fix for throttle after acro flip (was being kept at min throttle if pilot switched out of ACRO mode while inverted)
7) bug fix to acro trainer to do with roll correction 
8) prevent cli from being entered more than 20seconds after reboot.
 
Users are recommended to:
    Update Mission Planner to 1.2.41 and
    Update their flight code to 2.9.1b from the Firmware tab on Mission Planner. There is no need to go through a new configuration process in the Mission Planner.

 

Views: 99894

Reply to This

Replies to This Discussion

In the video file

00:15 motors start spinning in video

01:22 it starts to get out of controol

01:30 lucky to get some roll response saves it.

Fighting it trying to get it to return back to me untill

01:48 where it starts to go down into a bush. finish that at 

01:50

Hope that helps analyze the logs.

1st, much appreciation of the work done by the devs.

Old noob here who just spent more than a week getting bluetooth to work (yea no USB) with FW: 2.8.1 & MP: 1.2.44 ... had BT etc working perfectly, and was ready to calibrate and tune ...

Then I succumbed to that "Update now" to MP: v1.2.48 and now BT is KAPUT ... I assumed I needed to upgrade FW and got v2.9.1b ... but still no BT.  I have exhausted my troubleshooting skills. Error detail enclosed ... please HELP!

Attachments:

So is it just me or does there seem to be an abundance of "I crashed" posts lately with the new firmware out?

One more question,has the bug in the accro doing flips been sorted in 2.9.1b-dev=beta,many thank's Marty

From Jason

It was working for a little while. I did try the trunk a few weeks ago and it didn't work again, but I only tried once. I also tested it recently in the sim and it was working there, so who knows.
If you test it, go very high. Then if it doesn't complete, give it hard roll on the sticks to exit the mode immediately and return to stabilize. It recovers just fine.

It's a wonderful feature, and when it works it really makes an impressive demo. I even had it flipping in AP Missions using a hacked WP option. Pretty cool.

The problem is outside of the scope of the flight code or MP.  You need to get your BT working so MP can see it as a serial port.  

Why there are new or different parameters between 2.9.1b and 2.9.1b_dev?

I did a compare the list of parameters between 2 release and I did see new parameters in 2.9.1b_dev which are not in 2.9.1b or vice versa.

This is somehow confusing. I understood that between 2.8.1 and 2.9.1 there are new difference, but I did not expect between  2.9.1b and 2.9.1b_dev.

I did load 2.9.1b_dev as firmware, but using the 2.9.1 param (save in file) and looks Quad it responding different.

Should I keep the default params coming with the firmware release and just adapt the parameters I need?

When I said  Quad it responding different I am refering to Loiter and Auto and GPS (MediaTek) functionality.

With 2.9.1b I can not more use the Loiter or Auto, GPS is jumping as crazy.

When I switch from AltHold to Loiter, Quad is reacting aggressive (someone said as a Porsche .. I totally agree)

If you have to ask you should not be using the -dev firmware.

2.9.1b is recommended for regular flight.

How about an option in the next Mission Planner to let you choose Internal or External Compass and if External Compass, allow your choice of orientation ??

We're working on it.

Hi, Me too the same thing happens, but the people of "DiyDrones" I replied that the GUI "Mission Planner" again has that problem of calibration of an accelerometer and solve it for the next version of the MP. Try terminal (CLI) through the MP and see that perfect calibration.

It must be that they are trying to reconcile the "MIssion Planner" with controller "PX4" and this somehow affects the timing of the communication frame between the APM and the MP GUI, since the APM uses Arduino Bootloader and a speed different from the communication protocol processor PX4 plate. Surely that is the problem there.

Good Friends. Excellent News.

Sincerely ...
Mr. Rafael Villegas
+58-412-4971857
Valencia-Venezuela

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service