Hi. I have a Hexacopter with Arducopter 2.017 and it flies well.

I have loaded 2.018 and usig Apm a motor of my hexa has burned.

Has this happened anyone?

Thanks.

Views: 2023

Reply to This

Replies to This Discussion

I've updated that warning to be clearer.
Hi Chris, when was that added? Seems to be a relatively new addition, does this replace the previous advice to always connect the lipo? Or do I no longer connect the lipo now?
I have also had this problem crop up with various other FC's so it is not just an APM problem. In every case it was the ESC that was at fault. Only last week I had a brand new TURNIGY PLUSH 40 amp that would not start properly I have also seen that happen with the HiModel copy. Nearly all of that type of controller are made at the same factory, essentially it's the same controller rebranded with a slight firmware change. Both are 400 hz. There is a high proportion of faulty components out there. Unfortunately once you shorten the wires or put a soldering iron on it then warranty goes out the window, so It pays to check them first before installation.

ip9: I'm not quite sure I'm following. The advice is to connect the LiPo but disconnect the 4-wire cable connect APM to the ESCs. This is the warning that has been in the manual since we launched AC2:

 

I've also seen the motors act funny in the following situations:

- Using the reset button on the sensor shield or board

- Connecting from USB (in particular with the ArduCopterConfigurator but also the Arduino monitor and CLI)

- Uploads

 

It doesn't seem to be related to the software code at all since I've seen this happen with both many versions of the old Arducopter code and 2.0.16.

 

During resets it seems to depend a lot on the ESCs as well. Some of my ESCs (I have different versions of the same no-name thing) first emit a warning saying that the signal has gone out of bounds in the upwards direction right when I press reset, then shortly after it does another warning that the signal was lost entirely (flatlined) and then a notice saying that the signal has been recovered. This happens on every reset, always - easily reproducible - and takes around 1-2 seconds total. Others just move the motor a bit and get hot to touch if you reset 3-4 times in a row (didn't try more than that).

 

During flashing I have no clue what is going on. I noticed some of the motors moving a bit and getting hot once and tried different things. It seems that setting "soft start" on the ESCs will remove the heat problem but instead it will sometimes randomly spin up a propellar for a few seconds, then lose the signal and spin it down again. Sometimes it works flawlessly, though, and other times it is a weird mess of beeping and spinning propellars. It is not really a problem because the documentation clearly states that powering the motors should be avoided when connected to a computer, but some people seem to take safety warnings as a challenge - in this case me included ;)

 

In short: For me it works to enable "soft start" until the problem is solved. Most ESCs have different levels of soft start, I just used "quick"... - it doesn't affect flying at all like the "slow" one does.

 

Yes this is not a code problem.

 

Nevertheless this is a safety issue and should be corrected. It is not good as well to have burned motors or ESCs. Some motors and ESCs can be higher than 50 or 100 $ each.

 

It is possible that some users users don't even know that one of their motor or ESC did suffer from a reboot, and could have flight problems because of this. This is a loss of time for developpers, who can try to chase problems where there are not.

 

 

 

So for safety and for cleaner beta reports, this should be corrected. It seems to me that a pre warm boot code or eventually a bootloader change should be able to correct this.

 

 

 

 

Sorry to be picky but it's still not quite right Chris. If you do things in the order stated in the new yellow box, you will still have the potential problem:

  • disconnect usb
  • connect lipo
  • reconnecty usb
  • oh, and now disconnect the 4 wire cable.

The 4-wire cable disconnection should be first or second I think.

Rob

 

 

Do you think that the bootlaoder reset PWM and I/O setup registers ?

 

I'm not sure. If it is not the case, then I/O and PWM registers should be reseted before AVR warm reset.

 

 

Rob, that's not the way I read it. The disconnect cable part is not a forth step, but a reminder of a standard procedure that we've emphasized before several times in the manual.

Gents

My workarround is as follows:

- Never connect the LiPo when connecting the USB

- solder a diode between ESC + and APM. This way there will be now powerdrain from your esc and no motorspinning when rebooting at USB connection time.

 

But I agree, the problem should be resolved for the next APM / Bootloader release.

 

Best

Christof

 

 

I think that there is no absolute need for powerdrain sinking to trig problems, because the APM board is outputing PWM signals during reboot or firmware load.

 

 

The powerdrain does not cause the problem. With the diodes you just keep the one prop from spinning and prevent from USB power break down.

ACM Issues 110 & 117 describe the problem.  

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service