I was just playing with my apm 2.0 and minimOSD and everything was just working fine, then suddenly all out of nothing I stopped to get "heartbeat packet" so the minimOSD could not get messages from APM 2.0, then I tried to connect APM to mission planner but with no luck. then I to my ohm meter and started to measure an I found out that there was only 2.3 ohms from GND to RX0 on UART0, just to be sure, can anyone measure the resistanse on their board between RX on UART0 and GND (I am pretty sure it should be reading something high but not so close to zero)

see picture to know where to measure if you don't know it already :)

thanks in advance!!! :)

Views: 204


Reply to This

Replies to This Discussion


In the schematic and also on an APM2.0 board I have, the UART0 rx and tx pins from the connector on your picture both go through a 1.0 kOhm resistor before continuing to the muxer (the TS5A23157 chip). Damn, I also see and measure now that they go directly to the ATMega2560 pins 2 and 3.

I have several megaohms there.

I would probably try to lift pins 2 and 3 on the 2560 off the board (some fine tools and skills are needed). Does it no longer have 0 ohms? Then the ATMega2560 has had an input welded to ground.



Thanks very much for your reply :)

I did think this just the same way as you, I have lifted pin 2 on ATMega2560 and when I measure just the pin 2 resistance to ground I get 2 ohm so it seems obvious that the RX on UART0 is broken/faulty so I can not use it any more, but do you know if there is a psossible solution to this? I was thinking if I could use UART0 instead of UART2 to communicate with the APM, I know that the arduino bootloader uses UART0 to download new program to the APM, but I was just thinking that I could have mavlink communications on UART2 to connect to mission planner, what do you think? if I need new firmware on the arduino I can propably download it straight through the programming header/ICP (In circuit serial programming)

please tell me if you see any possibility in this or any other solution so I can connect apm to mission planner :)

best regards

Hi, I can only think of replacing the atmega or the whole apm2. Replacing the atmega will not cost you much. You will need an isp programmer to flash a bootloader in the new one. Of course you can also use one to flash a build of the firmware with UART2 support into the old one... still I would not recommend to fly with partially defective hardware. Replace the atmega...
Regards, Soren

Hi, I just wanted to tell you that I replaced the atmega2560 :) and it works now and I am damn proud of myself to be able to replace this chip ;) I used small baking oven to heat the solder up and then I could "peel" it off with tweezers.. the most problem was to solder it back in place because I had some solder bridges, but after some time with the solder wick I was able to remove the solder bridges and now everything is working like new :D

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service