I have run into some problems with the PPM encoder on my APM. The trouble begun when i installed the APM in my Twinstar II.

After installation i could not switch autopilot modes reliable and after
installation of all servos i the yellow LED started to flash randomly and the
servos started to move by themselves. For brief periods it worked but as soon
as i started to move the servos the problems got worse.

First i suspected the long servo leads and dual ESCs so i installed ferrite
rings on all servo leads. I also did some test flights without the APM without
any glitches.

As soon as i added the APM to the equation the trouble was back. When i tried
to connect servos directly to the APM it seemed to work better so i still
suspected the long servo leads. Next thing to test was to add opto isolators on
the servo signal cables. This made no difference…


I have also tested with different power sources and different receivers without any better result.


As a last test I decided to try to upgrade the PPM software. I downloaded the Trunk and built it. Downloading to the 328 worked, but the result is that I have no
control over the Decoder. It is stuck in AP control and. All three LED’s are
lit regardless of what I do.


I’m running out of ideas. Can someone point me in any new direction?


One question is, what revision of the PPM  encoder is the best to use. What version is pre installed in the latest APM’s?


Best regards



Views: 1461

Reply to This

Replies to This Discussion

The first half of your programmer log is from setting new fuse values (-U lfuse:w:0xe2:m -U hfuse:w:0xd9:m) that will not work with the 328p as it is used on the APM1.

grateful for help, thank you, I saved my trusty apm 1.4.
causes of the problem: is charge of the updating the latest version of ppm. from the download page. this code was wrong it was not for 328p.
that change the fuse
change the fuse
Low fuse: 0xFF
High fuse: 0xDF
Extended fuse: 0xFE,
load version v0.9. 87

for developers, check the download page
for users expect developers verification

Hi have the same problem.
Have the APM 1.4 with version 2.9.1, the encoder with the version 0.9. 87
The Fuse bits I've also checked. These are OK.

I raise the throttle stick, the blue LED flashes faster.
But in the terminal I get no feedback at:
- Calibration
- Test radio
- PWM test

the artificial horizon responds in the mission planner.

Does anyone know where the error is?

regards Bongo

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service