Warning: If you power the APM 2.5 from a BEC you should include the diode fix used on the APM 2! It drops the voltage to 5.5V which is what the 3DR Power Module does!

 I've noticed a lot of USB connect issues lately and I have found some solutions. There are and could be several reasons for this. It could be hardware or software. It might be the connector on the board. It might be PPM and it might be something else. So if we all get together in one place we might have better luck solving these issues. So if you have a connect problem let's get to work on it here. Please be civil with me and I'll try and help. Together I think we can work this out. I don't care if you have a clone. Has nothing to do with finding a solution as far as I'm concerned. Be prepared to get dirty and have your camera ready and send screen shots too. Thanks let's fix this.

First things to try: PORT CONNECTIONS and COM PORT

Check com Port Speed in Mission Planner (115200)

Make sure of Com Port in Device Manager.

Turn off Bluetooth.

Remove any USB Devices you can.

Swap around USB ports.

Try a different USB cable.

Second things to try: SOFTWARE and DEVICE DRIVERS

Mission Planner checks for updates when it starts (if connected to the internet). Have you checked for Updates?

If Mission Planner just updated run threw the Port Connection and Com Port checks first.

Try installing USB Driver http://ardupilot.com/downloads/?did=19 (APM 2)

If you have another PC install Mission Planner on it and see if it works on it.

Uninstall Mission Planner and reinstall from MSI http://ardupilot.com/downloads/#Mission_Planner_3_raquo

If you having HUD display not moving problems-

Try installing latest STABLE FIRMWARE BUILD from http://firmware.diydrones.com/



Update/Reflash PPM Firmware

APM 2 http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder

APM 1 http://code.google.com/p/ardupilot-mega/wiki/APM1Encoder


Mission Planner woes!

Make sure you have this font.


If you need to uninstall and reinstall Mission Planner

Make sure you go into device manager and uninstall the USB driver!

Make sure you have the proper .NET installed for Mission Planner (4.0 for the latest)

Make sure you install the MSI Mission Planner.

Make sure you reboot after making changes.



 I now offer a service to repair your APM for a $20 flat rate. If you send me your APM along with $20 and a self addressed return envelope with postage so I can return your APM to you if I can repair it or not. If I can't repair it I'll return $10 to you along with your APM.

Monroe King

995 CR 3040

Lampasas, Texas


 I'll be posting photo's/videos of repairs so others can learn too.

 I'm working on JTAG and UART0 work arounds that may give acceptable results for some.

Warning: Do not exceed Abs MAX input voltages when connecting the power supply or you will damage your board.
Warning: Connecting USB when you have input voltages at the high end of the range (near Abs Max) can damage the board. Disconnect battery before connecting USB or test input voltages so they are within the specified range.

Power Options Nominal Abs MAX JP1 status
Power on Output PWM connector 5.37V +-0.5 6V JP1 connected
Power on Input PWM connector 5.00V +-0.25 5.5V JP1 connected

Views: 56231

Reply to This

Replies to This Discussion

I just mailed out the board yesterday. Hopefully it'll arrive in 3-5 days.

did the board arrive safely?

Since sometime around a month ago I have also been bothered With USB Connection problems for APM. This is With several Boards and all working well earlier on the same computer.


But yesterday I also had problem upgrading my New Martinez Board and came across this solution for Martinez Board USB problem. And this also solved my APM USB issues!

The problem was FTDI driver Version 2.08.28 needing replacing with Version 2.08.24

This document tells how to replace the FTDI driver to an older Version.


Symptoms for me were connecting to Windows, hearing the sound of USB Device Connection, and after a few Seconds disconnecting again. Sometime also stay long enough for starting Mission Planner and then suddenly disconnect. Or a rare time staying on long enought to upload firmware and download logs. Not a very big problem but I have found it strange and thought it was my computer USB ports.

But With the 2.08.24 firmware this now working as before With no Connection problems.



Got a replacement in the mail and it works great on all of my test platforms.

Could you post a link to the "diode fix"?


anyone can help me please ?
i've my board broke when i release the gps when it's on
now the red and blue led stop blinking and can't connected to mission planner

did you already send the boards out? I have since moved locations so I'm a bit worried if it got sent to my previous residence

I think I'm experiencing the same problems as described in the OP.

I have the RCtimer apm 2.5 and when I first got it i connected via USB to MP and loaded on the arduplane firmware.

However now the USB connection seems to not work properly. The computer will detect the board normally most of the time. And in some instances I can connect to MP to start the calibration. However, the board always disconnects from MP and will no longer reconnect and will show up as unknown device in device manager.

I've tried all the fixes listed except for reflashing.

Telemetry via the radios works perfectly but I need the USB connection to calibrate the board.

Is replacing the mux chip the solution?


Mr. King,

    Are you still offering the service of autoMUX chip replacement? Mine has seemed to cook itself (even melted through the pink foam in the case!). This must have happened when I plugged up the USB while bein powered up with a LiPo through the 3DR Power Block. My FC will not talk to Mission PLanner and I am in DESPERATE need of repairs. Thanks! 

I think my APM 2.5 is bricked, but I'd like to know for sure.  When I give it power (USB or ESC), only the green LED comes on.  I've been reading about using a JTAG to talk to the processor - are there any basic instructions anywhere?  Or does anyone else have any other suggestions?

Is there any way how to detect if the MUX chip is wrong?

I had wrong 3,3V regulator and after replacing it, the board was working well for 2 weeks. Now I am unable to upload any firmware or communicate with the board via USB, or telemetry.

Monroe I've had some light crashes with my quad, so i wanted to see what was going on. Everything seemed OK in mission planner untill i moved the quad around by hand then the gyro went nuts. i now get (bad health gyro) is this something you would want to try and repair? 3dr apm 2.5


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service