Warning: If you power the APM 2.5 from a BEC you should include the diode fix used on the APM 2! It drops the voltage to 5.5V which is what the 3DR Power Module does!

 I've noticed a lot of USB connect issues lately and I have found some solutions. There are and could be several reasons for this. It could be hardware or software. It might be the connector on the board. It might be PPM and it might be something else. So if we all get together in one place we might have better luck solving these issues. So if you have a connect problem let's get to work on it here. Please be civil with me and I'll try and help. Together I think we can work this out. I don't care if you have a clone. Has nothing to do with finding a solution as far as I'm concerned. Be prepared to get dirty and have your camera ready and send screen shots too. Thanks let's fix this.

First things to try: PORT CONNECTIONS and COM PORT

Check com Port Speed in Mission Planner (115200)

Make sure of Com Port in Device Manager.

Turn off Bluetooth.

Remove any USB Devices you can.

Swap around USB ports.

Try a different USB cable.

Second things to try: SOFTWARE and DEVICE DRIVERS

Mission Planner checks for updates when it starts (if connected to the internet). Have you checked for Updates?

If Mission Planner just updated run threw the Port Connection and Com Port checks first.

Try installing USB Driver http://ardupilot.com/downloads/?did=19 (APM 2)

If you have another PC install Mission Planner on it and see if it works on it.

Uninstall Mission Planner and reinstall from MSI http://ardupilot.com/downloads/#Mission_Planner_3_raquo

If you having HUD display not moving problems-

Try installing latest STABLE FIRMWARE BUILD from http://firmware.diydrones.com/

Third things to try: FIRMWARE AND HARDWARE FIXES

CAUTION: USE THESE FIXES ONLY AFTER ASKING FOR HELP! IF YOU ARE IN WARRANTY CONTACT 3DR or SELLER of your board FIRST!

Update/Reflash PPM Firmware

APM 2 http://code.google.com/p/ardupilot-mega/wiki/APM2Encoder

APM 1 http://code.google.com/p/ardupilot-mega/wiki/APM1Encoder

IF YOU GET THIS FAR ORDER A NEW APM!

Mission Planner woes!

Make sure you have this font.

http://www.fontsupply.com/fonts/A/Arialn.html

If you need to uninstall and reinstall Mission Planner

Make sure you go into device manager and uninstall the USB driver!

Make sure you have the proper .NET installed for Mission Planner (4.0 for the latest)

Make sure you install the MSI Mission Planner.

Make sure you reboot after making changes.

 

(Edit) THIS IS A WORK IN PROGRESS!

 I now offer a service to repair your APM for a $20 flat rate. If you send me your APM along with $20 and a self addressed return envelope with postage so I can return your APM to you if I can repair it or not. If I can't repair it I'll return $10 to you along with your APM.

Monroe King

995 CR 3040

Lampasas, Texas

76550

 I'll be posting photo's/videos of repairs so others can learn too.

 I'm working on JTAG and UART0 work arounds that may give acceptable results for some.

Warning: Do not exceed Abs MAX input voltages when connecting the power supply or you will damage your board.
Warning: Connecting USB when you have input voltages at the high end of the range (near Abs Max) can damage the board. Disconnect battery before connecting USB or test input voltages so they are within the specified range.

Power Options Nominal Abs MAX JP1 status
Power on Output PWM connector 5.37V +-0.5 6V JP1 connected
Power on Input PWM connector 5.00V +-0.25 5.5V JP1 connected

Views: 56232

Reply to This

Replies to This Discussion

Got a reply from 3DR. Will try to replace the automux chip now - if I find it anywhere. Problem is that Mouser and Digikey want $20 shipping costs which is ridiculous for a $0,75 item! I asked 3DR if they can supply it.

Good news is, it's a "long-legged" SMD part, so soldering by hand should be possible...

Part#: TS5A23157DGSR

Location:

Well... Add shipping back and forth and you are almost at the price of a new RC-Timer Arduflyer...

For US residents (assuming that you are in the US too) that would probably be a good solution for a great price. But not so much for EU-residents. The customs paperwork alone is a bitch if you send something outside the EU for repair - because you don't wanna pay VAT again when it's sent back.

RCTimer ships for free btw :).

Count me as another person bit by 3v3 regulator issues.

One board started showing intermittent signs of 'ESC unhappy (repeating beeps)' at boot, unless power was first applied via USB, prior to applying battery power (via 3a turnigy BEC to input lead with JP1 disconnected).  That never occured until about a week ago.  The compass started showing intermittant unsual behavior, so I assumed the board was just suffering from 'accumulated trauma'.

So, I replaced the first board with another.  This board actually complained about 'dataflash not present',  I didn't notice that initially, but did after I had already performed a number of test flights, and noticed the compass was 'odd'.  I was going to recalibrate using tlogs, but then saw any attempt to access the logs and it 'hung', upon boot via USB, it showed the 'dataflash not present' message.

Both of these issues are symptomatic of the 3v3 regulator not functioning.  I did a voltage check, and saw 2.0 volts across the leads on the replacement board, and saw 4.0 on the first board.  I'm assuming both of those are significantly out of spec.  Excess voltage probably was 'marginally functional', insufficient voltage was just 'non functional'.

I'd like to take you up on the offer for a $20 flat rate (times 2), to repair these APMs.  I'm hoping replacing the regulator will resolve the immediate issue on the 2nd board, and perhaps also resolve the issue on the first.

Thanks again for your help Monroe.

I bought my APM a few months ago, plugged it in when I first received it and it connected fine. Upgraded MP software and now the board is not recognized on any computer (yet standard Arduino Uno is). I've tried all of your suggested troubleshooting.

How long is warranty on these? This sucks for me as I'll prob have to pay shipping (im not in US) and wait another month to see it

Hello, I have a quadcopter and I am using ardupilot 2.5 with arducopter 2.9 . I have all ready to take off ( I tried one time and my quadcopter flew very nice ). I only want to use mission planer to fly but I dont know how to do it.

I have visited a lot of pages where They only say how to upload missions but they dont say how to take off. 

I have uploaded missions but I dont know how to play it.

Please could you tell me how to take off with mission planer.

Thanks.

Auto take-off can only be done as part of a mission. Otherwise you must use your transmitter's throttle stick

Thanks again for your help Monroe. I submitted a ticket last Fri but haven't heard from 3dr yet. I'll keep you posted.

Help desk contacted me today to send the board in for replacement.

I seem to have similar issues as Jon. I have a APM 2.0 board purchased around this time last year but haven't mounted it on a quadcopter until now. I had it working just a week or two ago with Mission Planner, but just recently found that I could not even detect the device through Device Manager under Windows 8. I have also tried connecting the APM on a completely different computer with Windows 7 and nothing shows up under Device Manager either.

All the LEDs work when I plug in the board via USB so I know the board is working. Occasionally, the Rx light is solid and the Tx light flashes rapidly (plugged usb only). I also know the board works via radio since when the ESC's and receiver are plugged in, the quadcopter can still be controlled. However, I cannot get any computer to detect the board so I cannot reprogram or calibrate.

I have attempted the PPM reflash but not having the board show up under Device Manager makes it difficult. I think got to around step 5 following this (http://copter.ardupilot.com/wiki/common-program-the-atmega32u2-ppm-...) but I don't get the Windows usb connect/disconnect sound. So I'm worried that it may be one of the IC's you mentioned that may be gone. I'll try and mail my board in sometime this week, thanks a bunch for the help.

3DR sent me an RMA last week for same issue, sent board back on Fri. Lexi promised to send a replacement out Mon morning but I haven't received confirmation or a response to my email in the past 2 days.

Dear 3DR, why is this so frustrating? I want to love you but you make it so difficult.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service