Got a problem that I can't seem to figure out. I have an Turnigy 9x that I upgrade the firmware to er9x and since then I can't seem to arm my quad. I have reloaded Arduocopter 2.8.1 a couple of times, I can connect with the mission planner. I can calibrate the radio with the mission planner. Telemetry is responding when connected to the planner. Since I am pretty new to this I don't have enough background to figure this out. I was able to arm it with the stock firmware before I updated to er9x.  Can anyone help?


Views: 3414

Reply to This

Replies to This Discussion

Sounds like one or more channels got reversed. Try the various other arming possibilities (bottom left, top right, top left) and see if one works. That will tell you which channel got reversed. 

Also, needless to say you should go through the RC calibration process again, as is the case anytime you change your RC system.

Actually I did try that but I did it again holding for 10 seconds at each corner before giving it throttle with no results for any corner I tried.  Also did the calibration each time it reloaded 2.8.1. The radio appears to respond in the mission planner, I just can't arm the APM.


I just had the same type problem and i re-calibrated the radio using the mission planner and all is working fine now.

Have done it several times. No love.

Also tried to set the mix to 80% on all channels as suggested on the 9x forum with no result.


make sure that the stick layout is for mode 2 and moving to RC equipment.  

It is mode 2, Not sure what you mean by "moving to RC equipment". 

Hi Dan, do the esc's give a warning beep like it was started with the throttle up? I mention this cause that's my problem at the moment.  On the other hand, as you updated your tx, try putting servos on the rx and see if they have the full throw as it was before the update of the tx (if you remembered or did so before)

Choppy is right. Try connecting a servo to different channel and or notice them on Radio calibration page on Configuration page of APM. If you have a wrong channel hooked up, you will definitely notice it. Also remember that arming / disarming requires a 100% yaw to the left and right respectively along with 0 throttle. So in case you might have limited the stick input, it won't work.

Had a friend with the same problem but this time it was because the Rx was not bound properly with the TX (spectrum DX8).He has two quads where one quad  was bound ok but not the other which tells me the model memory was not done right.

(The radio calibration page did not show stick movements on one unit )   I guess the DX8 cant bind to two receivers at different times with the same profile so model map should be done.

I'm adding my experience with this. after hours it turned out that my throttle had to be trimmed. go to APM's radio configuration and trim your radio to fall within the range of the calibration bars.

Alexander, THANK YOU.  Spent 2 hours with the same problem and then Googled for help which led me to this post.

Your solution resolved my problem within minutes. 

Very grateful.



Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service