I recently upgraded to 3.1 on a trex 600 running digital servos and I am getting a random twitch. I thought at first it was the ppm encoder so I re-flashed it like I have done before on other APM flight controllers. After doing so I didn't see any changes and it seemed to twitch just randomly like before. 

On another note I did see more twitching if I ran higher voltage to the servos. 

Of course I haven't flow it in this configuration.  

Has anyone seen this problem?

Views: 1834

Reply to This

Replies to This Discussion

Yea mounting PX4 upside down would be much better.

My PX4 is like hanging with damping spring at the moment, I have to use 50mm screws to build a chamber/box for a damping mount. The little box is about 50x50mm above the tail boom mount, took too much space and doesn't look quite cool :)

But I'm considering placing the PX4 under the main frame, and put an APM 2.5 on my friend's 450 (perhaps without casing) so I can have two heli's to compare. 

I'm also having this problem using ppm, but since I can't adjust the frame rate on an 8fg I'm going to switch back to a standard pwm rx setup.

I'm still seeing the exact problem using PWM, so it's now PPM.  It's very specific; it only happens when I yaw left and aileron right.   I'll fall back to older firmware to verify before I start looking for a cause. 

Also, you can't use the new mission planner software to do heli setup can you?  I can't find the heli menu.

Is this on APM or Pixhawk?

Heli setup is now under the "Initial Setup" section of MP.

Well I was being stupid and had my y cable connected wrong and was pushing 12 volts to my servos, so problem solved.

I still don't see the heli setup in any of these menus with the new apm planner, or am I just blind?

I got some new twitching problem, very interesting one.

Just upgraded from Turnigy 113MG to 306G, upgraded PX4 to 3.1.2 and started to set up. As soon as I long press the safe button, servos started to move like normal, but the aileron and pitch servos are twitching like crazy without stopping. these two servos jump up and down at the same time and they jump very fast.

Having been looking for the cause for a while until I realized the twitching is synchronized with the interference noise coming out of my speakers. It's the telemetry. As long as my finger touches the antenna, the twitching is gone. If I disconnect the telemetry, twitching is gone as well.

I can't explain why this happens, seems the 433Mhz wave may have generated some signal into PX4 but my finger sure won't block the wave totally. Maybe it's a grounding problem, I don't know. Besides, using the 113MG servo doesn't reveal this problem, I have rarely twitching with 113MG. Further more, I'm not sure how much it has to do with the wiring, my wiring is now very simple and direct. The servo doesn't twitch at all if I haven't release the safe mechanism of PX4, and the position of the telemetry doesn't change the twitching behavior.

I ran into this problem as well. What I found was my connection between the 900mhz link and the wires that plug into it were not very tight. I was able to fix this by crimping new ends on the wires. Now when I plug it in its got a nice tight fit. Those plugs can only be taken on and off so many times before they become loose. 

Yeah, we used to have problems back in the day with Xbees telemetry modules causing a problem very similar to this.  In my case, it was more of a slower or smaller movement you could hardly notice, but same idea.  It seemed like some servos were more prone than others.  And there was some relationship to ground and power wiring of the servos.  But the telemetry was the root cause.  Something about the ground plane of the module.  Touching the antenna would stop it.

3DR Radio modules completely cured it.  I haven't thought about it much after that.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service