Frequently asked questions are about powering an APM2.5 or why the same does not work or why it has failed.

Here is a simplified schematic showing the major components of the 5V/Vcc circuit on the APM2.5

Target Audience: Readers who do not have Eagle or are confused about using it.

You Need: Basic electronic schematic reading ability

Note that I have separated the PWM Output section into the upper left corner with a heavy purple line that is bridged by the jumper JP1 on the APM2.5. This is to emphasize that diode D1 passes current through JP1 (and drops voltage). The remaining energy is then called 'Vcc'.  Everything outside the purple corner is Vcc.

This is why the USB will power the APM2.5 when connected to a computer/USB hub. Note the fuse on the APM2.5 side of the USB connector AND another fuse on the output of D1. Another change from APM2.0 is the D4 6.0V Zener diode. If an over voltage is applied to the board, D4 will crowbar what it can to protect devices.

As with APM2.0, any 5V source connected to any of the indicated Vcc/5V points outside the purple corner (with GND of course) will power the APM2.5.

Also of note is the 'Mystery Port'. This port takes 5VDC before D1 and the fuse and is called 'JP_VCC'. Other clues to the mystery are the lines to 'ADC 12' and 'ADC 13'. A mystery indeed!

Any errors in this drawing from editing are mine.

I hope this can be used as reference for solving problems.

-=Doug

 

27-FEB-2014 Eagle files are now located HERE

 

Views: 73906

Attachments:

Reply to This

Replies to This Discussion

HI Doug,

No, JP1 was not installed, as a matter of fact it did not even come with jumpers. Only the modules powered by the 3DRPM have all gone up in smoke: uBlox GPS and MinimOSD (Telemetry port). The 3DR modem is still in tact. XT-60 connector, so I'm flustered.

The receiver (powered by the ESC) is still fine.

A switch of some sort will be installed, that is for sure.

Waiting for 3DR to get back to me.

Thanks,

Alex

@R. D. Starwalt 

can you add a link to Altium Schematics and PCB Files above, as it may help some members

Thanks

Philip

This discussion will probably cycle off the Featured list after the next release of APM (my APM2.0 did). I have no control over what becomes a featured discussion (and was happy to be selected).

For those who do not know, Altium is another electronic design software package. Eagle, by CadSoft, has had a strong following in the hobby world with the free-to-use version. If none of this makes sense to you, think of two different word processors. Rather than words, this software works with electronic parts.

My intent with this discussion was to help users understand the power supply side of the APM2.5.  The skill set of folks in this hobby is all over the map and if a simplified power diagram helps someone get in the air and have fun, so much the better.

Now that the 'mystery port' was revealed to be the new 3DR Power Module connection (I had guessed as much before release), I might update the graphic to show it.

Most likely, new releases of APM will utilize the 3DRPM.

-=Doug

What are the pinouts of the I2C port?

I'd like to setup a master/slave setup with an Uno = http://arduino.cc/en/Tutorial/MasterWriter- but need to know which pins are SDA, SCA, and GND.

I don't see the I2C port on the APM2_5SimplifiedPower.PNG drawing - am I missing it?

Nor on this doc: http://stuff.storediydrones.com/APM_v25.pdf

I picked up a Hirose  four port connector - and it seems to fit:

http://store.diydrones.com/DF13_4_Position_Connector_19_cm_p/ca-000...

According to the manufacturer, pin 1 on this cable, corresponds to the single red wire:

http://www.hirose.co.jp/cataloge_hp/e53600014.pdf

So I know which pins are 1-4 (counting one from red) - on the patch cable.

I just need someone to decode the Eagle files and tell me which pins on the APM 2.5 I2C port are tied to SDA, SCA, and GND, so I can route the correct cabling to the Uno's A4, A5, and GND...

Thanks.

The I2C port is connected to the 3.3V section of the APM.

I left it out of the drawing because the emphasis was the 5VDC/Vcc supplies.

Here is the I2C port wiring:

 

If you looked a little closer, you had your answer on the pdf...

 

You are welcome!

-=Doug

3DR is replacing all my components under warranty and shipping 2 day Fedex. Great service! In the mean while I can report that installing a Polulu Low voltage switch seems to work well.

 

you are a lucky guy  ...I got a 100$ discount  the old board is on my desk...feel like crying...

USB problem

 

When I connect the USB I get the flashing A and B led as they should. After a time they go out and the B led remains on solid and it won’t link to my computer. Any ideas on what to look for?

 

The LED status information does not list this condition?

 

 

 

 

Thanks Tim!

This will help those that are adverse to Eagle or learning how to use it.

The 'Simplified' schematics usually required me to edit/flip/translate several parts on the Eagle drawings to better reflect a left->right flow of information. The orginals do not take this into consideration and the reader ends up wandering all over the drawing looking for related connections.

-=Doug

Mike,

I apologize for missing this previously but hopefully you've sorted it out.

This would have been better asked as a separate question in the top of this discussion section (ArduPilotMega 2.x hardware) rather than under this post. I do not have Admin rights to move it.

Did you find a solution?

-=Doug

When I connect power to my APM2.5, the leds ABC do not light up at all. I can contact the board through USB however. The ESCs are also not seeing the output pins except for pin 1. This has just occurred all of a sudden after several flights of having the board powered through the output side, with JP1 jumper connected.

Ewan.

hi

i dont know if im at the right place but i have a problem with my apm 2.5.2

after a calibration of my remote control nothing works.

when i plug the apm to usb the power up i see led red and blue flashing and after only red flashing

the tx and rx light always on, green led alive is on.

and nothing is detected in windows.

someone have an idea ?

thanks

 

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service