HELP!

Following a crash that wrecked my 1st DIY Hash-octocopter,

I have now happily completed my second, SteadiDrone based octo - real nice!

The APM2 board, that lived through the wreck, will now not power from the Lipo.


Power Scheme (4C Lipos)

2X Lipos -> Wiring Harness  (in parallel)

Wiring Harness -> 8X ESCs   !!! Power Up and beep

Wiring Harness -> CC UBEC -> 5v -> VOLTair power distro  !!! power tested & OK

VOLTair PDB -> (+5v / Red) power feed on output 2  **

APM2 Jumper: ON

Rx signals connected, including power from APM2 to Rx

** Note: All wires from ESC to APM2 have their +5v/Red wire CUT

          +5v is bridged to the second connector from the UBEC, all ground common.

           This has been tested and worked on my previous build.

 

When powered from USB only:

1. APM2 powers and boots OK

2. Firmware loads OK, COM connection established, Radio Calibration OK etc.

3. Magnetometer OK, North reading OK

4. GPS OK, correct 3Dfix established (5 sats..)

5. Input and Aux rail shows ~4.75v

6. Output rail @ 0v, but I assume that is normal

8. Output rail Signal shows ~2.5v,

9. Board will not arm

When Powered from LiPo via UBEC (no USB):

1. APM2 appears dead, no lights, nothing

2. All 8 ESC's play their startup note and proceed to beep in unison once a second or so

3. Output rail power reads +5v

4. Input & Aux rails read +0.25v

 

When Powered in parallel (USB + Lipo):

1. There seems to be no communication between Rx/APM2 and Output rail / ESCs,

2. Can't arm board

3. Can't calibrate the ESCs with the throttle procedure.

4. CLI motor test doesn't work

5. Resetting APM2 provokes a beep from the ESCs

6. Reconnecting to PC/USB provokes ESC beep

Any ideas anyone, or is this board toast?

Thanks -

Gil

 

Views: 98

Reply to This

Replies to This Discussion

Gil, Have you looked over the possibilities shown on THIS schematic?

When you say 'VOLTair PDB -> (+5v / Red) power feed on output 2  ** ' do you mean you are inputting DC volts to the IO rail?

-=Doug

Hi Doug,

Yes, I did take a look at the schematics and it seems I have a blown out D1 diode, hunch.

As my power comes from a 5v UBEC, I tried the following:

1. Disconnected ALL 8 ESC connections from the Output rail, just to make

    sure non of the ESCs was shorting something

2. Ran an independent -/+ 5v connection from the 5v PDB board to the free slot (7th) on the

    Input Rail - VIOLA - Power to the people!!!

 

I am now looking into the following WIKI "Alternative ways to power your board" at

http://code.google.com/p/arducopter/wiki/APM2board

but the question remains, how would this be affected by a burnt diode?

As to your question:

Yes. This is my way of powering the APM2 directly from the UBEC 

(ignore the fact that there is a PDB in the way): Basically, since all GROUND is common,

I just run the Live (red/+5v) wire from the UBEC and spliced it into place of the red wire coming

from one of the ESC control cables. ALL the ESCs have thier Red wires cut, so in fact non of the

ESCs onboard BECs are supplying any current to the APM2.

Thanks -

Gil

OK, I tried this...

All 5v power supplied via CC UBEC, via a dedicated PDB just for 5v.

1. JUMPER REMOVED - two parallel power feeds to APM2:

- Output rail powered via UBEC

- Input rail powered via UBEC

2. APM2 lights up like a Christmas tree, good start :-)

3. Could Auto-calibrate all 8 ESCs using throttle method

    - thorttle up, connect Lipo, one BEEP, disonnect Lipo

    - Throttle up, Connect Lipo, some BEEPS, throttle down

4. At this point could rev up all motors with the throttle   :-)   ! ! ! (nothing beats a live octo!)

BUT,

Once starting fresh, after Re-Connecting the Lipo or doing a RESET, I can't arm the ESCs    :-(

 ? ? ?

Gil

Reply to Discussion

RSS

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service