APM2 GPS Red LED and data help (CRASH REPORT, ANYONE ELSE?)

HI everyone,

I have been struggling with the APM2 that I have just installed and have been trying to fly in Auto and RTL modes. I do have the plane flying great in the stabilize mode and the fly by wire mode also works.

When I switch the plane to RTL or Auto mode the plane does fly itself (circle) and hold altitude but it does not go to the waypoint locations and it does not circle over the home or launch point. Every time I have flown I have waited for the blue led to go solid and also the 3Dfix led is solid. I have also connected to the computer outside and in the mission planner it says 3Dfix. I do NOT ever get a red led to stay on. The red led does flash when the board is first powered up but then has never stayed on solid like is says it is supposed to. See the link.

http://code.google.com/p/ardupilot-mega/wiki/LED

That brings be to my next problem. It was suggested to me to look at the data log and see if there is an actual gps lock. When trying to look at the data log in the mission planner I do not see any horizon changes, speed or altitude changes. It does say the log is playing but I am unable to see any of the planes functions.

I have been struggling with this for a week now and do not know what to try next. If anyone could give me some suggestions that would be greatly appreciated.

Thanks

Ryan

Views: 2123

Reply to This

Replies to This Discussion

Hi Ryan,

I had APM 2 in my Bixler and worked great - Missions RTL etc - very cool. I then put it in my quad but it wasn't very stable so I will wait for some stable code. I have put it back in my plane and am now having the same problem as you. MP tells me home is spot on - I reset home - Wait for 8+ Satellites, push reset, wait a minute more to ensure HOME is set, and it just flies off into the ether circling away???

Not sure mate. I don't get the red light on Arduplane, but do on Arducopter.

Just keep plugging away

Thanks for the reply. Hopefully today I will get some time to try it out again. Since my last flights I have uploaded firmware for heli's and quads and now re-uploaded the plane firmware. I also am using a different computer with the mission planner installed. I am going to erase all the data logs in the APM. My first test will be to walk around with the plane in my hands and watch the GPS light and ensure it stays on. Then I will check that data log. If I am unable to read that data log like the others I am probably going to send it back.

If that data log works I will continue with the testing with flights.

No more messing around with this for me:))

Ryan

OK after trying many things today the AMP drove itself into the dirt. Testing today proved no guidance to GPS locations. During my third test flight while watching the plane circle and fly around lost in the air it suddenly went straight 90 deg down toward the ground. No exaggeration that the plane was flying level and then pitched straight 90 deg nose down. I switched the plane to manual and had the plane about back to 45 deg before it hit the dirt. So at least I know it was not a air frame / servo linkage or radio problem. 

Not sure about how 3D robotics will be about warranty on a unit that never worked and now is smashed. I have been emailing them complaining about the issues that I have been experiencing and now I guess I will see what they say. I am very frustrated with this and not sure if I will try it again or not??

Most everything survived with exception to the plane APM and lipos.

Anyone else experienced anything like this? 

Sorry to hear about this, I too feel a bit frustrated about APM.

Something similar, but probably not comparable, happened to me with an APM1. First, I had an APM1 that would boot with ArduCopter software, but not with ArduPlane software. This was probably due to some sensor malfunction. It never flew in a plane and was replaced by my dealer. The replacement APM1 worked quite nicely a few times, but then it took my plane plus camera down with some strange malfunction. (See this thread, if you care: http://diydrones.com/forum/topics/crash-investigation-arduplane-2-2...). The only thing to survive was the RC receiver, resulting loss is around 500$...

Most of the software development effort seems to go into ArduCopter software at the moment. Maybe ArduPlane is just not ready for prime time. Or maybe you just shouldn't get startet if you can't afford to loose a certain amount of money every month on your toys. I can't... :) I'm still considering if I should get a new APM or just forget about it for the moment.

One important thing to consider is the fact that 3DRobotics is only creating and selling the hardware for an open source project. I read a very informative post about this somewhere but I can't find it right now. Part of the deal is, you are on your own with your problems. If you are lucky, you will find community help. To be able to provide extensive support 3DRobotics would have to charge a lot more for a device of similar capabilities.

Support around here seems to only take action if something happens more than a hundred times or so. Singular events seem to be ignored mostly, judging from what I've been reading here for the last few months. The only reply in my thread mentioned above is from myself. It's about some conclusions I'm drawing from this whole mess.

Chris,

Thanks for the reply and I was happy you shared your post. Yes I did get a reply from 3D robotics last week when I was asking for help and they said they do not support the software only the hardware. But I do believe I had hardware issues now after this. Of course I could be wrong but who will ever know now.

One thing that is confusing to me is how the hardware only can be supported. If the software is not available the hardware would not work for me ( and the majority of others).

The only thing that I am upset about is not sending it back right away. I was hoping that I was doing something wrong or that there was a fix that would be brought up or that I would find here. I do thank everyone that offered suggestions and there help.

I do believe I will order another APM and try it again sometime. I might wait until the APM2 is in stock.

Any thoughts on why this happened would still be greatly appreciated.

Ryan

Ryan,

Like most open source projects, the ArduCopter and ArduPlane software is created by a community of volunteers, most of them here. 3D Robotics only sells hardware--technically, they're just "development boards", like the Arduinos that they're based on--and doesn't develop the software. I know this is confusing, but it's common to open source hardware projects. 

Please note that there are nearly 10,000 APM boards out there, and the vast majority are working fine. I'm sorry that you had hardware issues, but 3D Robotics is definitely there to help with those. They take their hardware customer support responsibilities seriously and definitely encourage people to get a RMA and send the board back to be checked out if they're having issues within the warranty period. 

The ArduPlane software is being very actively developed in the background, and you should expect a major release in the next couple weeks. It shares all the key libraries with ArduCopter, so all the work you're seeing on copter code is also going to show up in the new ArduPlane code. Most of it is focused on reliability and performance (as well as optimizing the code for APM 2), so I would recommend updating when it's out. 

Hi Ryan,

I was having similar issues.

I deactivated the Mag/Compass and all is well. I tried everything with the compass, read many threads, waved it around to calibrate it, then couldn't find a thread to set the values the calibration gave me (not declination). I also found that it would quickly switch from Manual to Stablise itself a few times and I had to flick the switch a couple of time to get it back. My radio setup showed no flickering between values??  which may have happened if it wasn't flat at the beginning (just clutching a straws for you)

Before this would fly in circles away from me and couldn't find home, showed in mission planner only Nth - W- S and nothing east of N or S.

Just flew a few 'missions' FPV with minimosd and it was, at last satisfying.

The mag issue means I won't put it in my quad or hex again and will stick with my Naza for now.

I believe it is hardware related as I had a similar issue with APM1, however this time CLI doesn't tell me "bad compass". I am not a programmer etc, so I have no clue like many of these other guys, but switching off the compass worked perfectly, I don't think Arduplane needs it, but Arducopter does.

Working it out is half the fun, crashing is S#$%.

There almost needs to be a flow chart for a procedure sheet depending on the plane build. ISO ???

 

It really looks like a propeller failure. If so the IMU did its best.

Thanks for the reply. I understand now. Yes it is a bit confusing and I am sure you have probably typed that same message a few thousand times. :)

I am looking forward to trying another APM2 and will look forward to the updates. 

It is impressive that volunteers that wrote the software.

HI,

Thanks for the reply. Your circling and flying away from you is exactly like I experienced in all but my last flight. Good to know that you were able to find a fix. The crash I experienced today was not a big deal I just hope to learn something from it.

The thing that messed me up the most was the logs. I am convinced now that there was something wrong. Earlier I figured I was doing something wrong when trying to read the data logs and nothing was working.

So to summarize I did learn to ensure that the data logging is working and to check the data. If things are not working correctly I will send it back to be checked out.

Funny thing is how do the gears in the aileron servos get stripped out in the crash. The plane hit about level directly into the nose. No damage to the wing at all besides striped aileron servo gears. Hitec 65HB servos. The tail boom of the plane cracked right in half and the stabilizer was hooked under the nose on the wire landing gear. Didn't have my phone on me and it was muddy where it crashed other wise I would have some pictures.

You are correct working it out is lots of fun. Glad your FPV missions have went well. Have any pictures of your plane?

Here you go.

Cheap and with PIDs already available.

I don't know much about electrics as I have only really sloped and mainly DS. But this was easy with a few mods on the spar. The last photo is my new one ($34) which I am putting esc and OSD in the fuz to save room and get the cog back without too much weight on the tail. (HK Raptor probably better and a bit more room but sold out).

Attachments:

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service