I'm having a bit of a problem with my quadcopter controlled by APM3.2; sometimes motors stop spinning mid-air and quad drops dead on the ground.

I'm trying to find the cause but have curiously found out that no logs are present. I've dug deeper and found out that LOG_BITMASK is 0 which means no logs are recorded. Ok, so I've put this back to 830, which is the default value, and wrote params to APM. Then disconnected, reconnected and .. LOG_BITMASK is 0 again! 

Logging worked OK some time ago but can't remember what change rendered this functionality broken. In the mean time I upgraded APM from 2.5 to 3.2, that is for sure.

I've tried putting APM in the oven, hoping for a quick fix, but nothing changed. I've tried this desperate attempt due to some reports saying that the regulator connected to dataflash might be broken or have unsoldered.

Is anyone else having this issue?

Views: 163


Reply to This

Replies to This Discussion

Did you fix the problem? I have the same issue. How did you do.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service