There is a preview on GIT right now. I flew a version of this


The PWM output has been set to 400hz (to counter the low pass filter in most Turnigy PWMs)

The DCM's Roll and Pitch gains were lowered to .03 (recommendation of Hein Hollander)

Mavlink has gotten a re-work for performance and memory savings.


Added a scaling factor to camera Roll And Pitch CAM_P_G, CAM_R_G in the params list.

Fixed some bad PID values for Alt hold that were giving folks trouble.

Exiting a WP for another is faster and more controlled now.

Added user hooks for those who want to execute their own code inline.

Increased loiter speed to center when the copter is flown > 400cm (now 800cm).


Loiter in action.


Views: 31804

Reply to This

Replies to This Discussion

pretty sure you checked them, but what about the subtrims?

I think Mr. Anderson is right ;) it must be something with flash and ios5 because I restarted the ipad1 after closing all apps and the problem is still there. Also waited for page to fully load. Never had this before upgrade to 5.

Here's a sample of how 2.0.49 performs on my frame currently. On this short hurried test I didn't happen to witness the best accuracy (it varies) but 2.0.49 is very different from and better than anything I've seen earlier. Ignore the slight jumpiness in altitude, the sonar signal is still a bit noisy.


I guess 250 is in cm, so 2.5 meters per second ground speed? At this point it never settled so it kept going around in circles.


8 meters from the waypoint at its worst.


The first loiter generally stayed withing an area with a diameter of 6 meters, the second used up an area with a diameter of 12 meters. There was noticeable wind.

My guess is still the declination isn't right or the frame is somehow affecting it. But I'm not 100% confident. 

Slight gyro drift of a few ° could also cause bad behavior.

I tried to enable current logging and couldn't. I typed "enable current" and nothing happened. However, I could enable/disable other types of logging.

Good point, since my magnetometer isn't soldered to the board. Having it off even by just a small bit could easily result in this... Jason, have you seen this blog post?

If that vulnerability could be eliminated or reduced, it should make for a more robust system overall.

Had some better success with 2.0.48 on loiter and ALT_hold(baro only) but still need some more tuning.

here is an onboard raw video, not the best  vid and its twitchy as I forgot to change the cam roll gain I was too excited to fly after being away for a week.

2.0.48 onboard raw vid / loiter, alt_hold test

Loiter 3:21 - 4:30 (i did pirouette 2x with no aggressive correction from quad which is good and it stayed within a 5foot diameter)Overall diameter of the loiter is about 6meters


Any suggestion how to trim down alt_hold? when I move forward like on the last part of the vid, alt_hold will stay on its height when  moving like a turtle or hovering with +/- 1~2ft but when moving fast, ie trying to chase then suddenly stop it will climb about 8~12ft then slowly creep back. Here are my current settings

THR_ALT_P    0.6

THR_ALT_I    0.01

THR_RATE_P    0.3

Jeff E: Any reason why you're still using 2.0.48? 2.0.49 is MUCH better...

no particular reason, except I wanted to fly immediately this morning. I just arrive last night with jetlag I didnt want to waste the morning with sun on the horizon. Lucky I did cause now its gloomy weather again dont think can make another run.


I did however checked the changes of 2.0.49 from the git

- only PID tweaks

- loiter correction speed

- and the camera gain added by jason (I already have on the code with different naming convention)

- oh and user hooks

I might install 2.0.49 after a few more test run/tweaks


Hopefully with the alt_hold(baro only), I might go for watpoint test but I cant still find a bigger space where I can fly att lower altitude to test it.

When I use .49 just one ESC gets initialized. When I loaded .47 all of them worked properly. Any idea what might cause this?


Furthermore, keep up the good work! :)


I think this is because the PWM frequency has been rised to 400 Hz and your ESCs don't like it.


You should be able to get the older mode adding this inside APM_Config.h and recompiling.



That worked! Thank you very much. I use the TURNIGY TRUST 45A SBEC Brushless Speed Controller, but it seems to fail with the new PWM setting.


I am going to test the .49, thank you all! :)

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service