Version 2.4 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area.  Although not as big a change as the 2.3 release, it still includes a respectable number of enhancements and bug fixes.




Bug fixes:


The default PIDs are optimized for a 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props, start by turning down Rate Roll P in 25% steps.


Thanks go to the numerous contributors including users and their detailed bug reports, developers and testers.  Hopefully all together this will add up to a nice smooth release!


As per usual, please post your comments, issues in this discussion.  For enhancement requests for future versions, feel free to add them to the issues list.  Note:  you can "star" an issue to receive emails when someone comments on the item.  On the dev side it helps us because we can get an idea as to which feature requests are the most popular by sorting by the number of people how have starred each issue.

Views: 64969

Reply to This

Replies to This Discussion

Has anyone some good starting PIDs for a Octo with about 1.5kg w/o battery and 850KV Motors?

Yup, very slick.  Drill holes large enough for the hose OD, and insert the little hose pieces.

Then attach those stud things, and push the plate down so the studs do into the hose pieces. The hose is now locked in place, and provide the damping.

Sorry to keep barfing out ideas.  Just brainstorming.

ArduCopter V2.4.1 (daily GIT version) - Compass issue:

Many users have already found the problem, then do not fly for hours with the current version of the GIT.
The new loiter works very well (by changing some default parameters), but with the compass that rotates it is impossible to test its true reliability.
Here my daily video with the compass bug, already reported to the dev team... and now it's freesbee time! :-)

 -= Marco =-
(AC Dev Team)

This compass issue is very weird. I'm using JLN xp1 version based on 2.4, and I implemented all the changes in the code since that, also updated the libs and my compass is still working well.

Was last: APM2/softerfoam/softfoam/thinply/hardfoam/frame

Did you try waiting a couple of minutes before the first arming(basically until the compass stops rotation on the display)?  I just tried this a few times and it consistently works everytime. Somehow got to do with arming the copter before or after the compass stabilizes...

It also might have a lot to do with people who are updating, resetting their compass offsets, and needing to get the offsets again.

The thinply isn't good enough.  It's too light.  And with the hardfoam, it's probably not doing anything for you.  Try a plate of aluminum.

I don't KNOW this will work, just an idea to try.

And those little studs look an aweful lot like helicopter canopy mounting studs cut down.

Thanks for the advice Ihab, but it should not work as well, or better said, has never worked that way.
Until yesterday i never had these problems.

To tell the truth I have given up on APM2 for the time being, the amount of time & effort  required to try insulate this thing against vibrations for me is just not worth it, I was getting no-where. The correct insulation window must be so small and with the hardware variations out there, wow. I'll come back to it in a few weeks when it's matured a little.

I have put APM1 back on the quad (on the same mounts), did some tuning and had 4 very good flights this afternoon, off to do some FPV tomorrow.

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service