Version 2.4 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area.  Although not as big a change as the 2.3 release, it still includes a respectable number of enhancements and bug fixes.

 

Enhancements:

 

Bug fixes:

 

The default PIDs are optimized for a 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props, start by turning down Rate Roll P in 25% steps.

 

Thanks go to the numerous contributors including users and their detailed bug reports, developers and testers.  Hopefully all together this will add up to a nice smooth release!

 

As per usual, please post your comments, issues in this discussion.  For enhancement requests for future versions, feel free to add them to the issues list.  Note:  you can "star" an issue to receive emails when someone comments on the item.  On the dev side it helps us because we can get an idea as to which feature requests are the most popular by sorting by the number of people how have starred each issue.

Views: 65142

Reply to This

Replies to This Discussion

Here a video of a test flight of the ArduCopter v2.5 firmware (offical GIT version Revision:1ed94f0064f5) done with a F450 DJI Flame Wheel quadcopter and the ArduPilot Mega v2 board.

There was a medium wind of 21 Km/h blowing and gusting from the left. You will see that the Loiter mode works well and that the quadcopter is able to fight itself against the strong gusts. In some others tests flights, I have also tested the RTL, super simple mode and off course the stabilize mode without any problem.

Regards, Jean-Louis

Just came back from the field after testing with the latest (as of yesterday evening) GIT v2.5.   My setup:  3DR frame, DT750 motors, 11x4.7 SF props,  APM 2.0 mounted on o-ring suspension,  GW: 1300-1400 grams depending on battery.

Wow!  By far the most stable and least drift I have ever flown.  Very impressive dev team!  I tested stable mode, alt hold, loiter, and RTL. 

Stable:  As stated, little to none of the drift I had become accustomed to since I started on my project.  I haven't tuned much yet, but it's very stable with the param file attached.  Aggressive flying doesn't seem to get it out of sorts.  There is still some minor drifting every now and again, but it's much improved.  This platform seems stable enough to finally do some aerial photography/film!

Alt hold:  Best yet, and i only use the baro.  It does seem to sink a bit when aggressively flying in this mode ( 3 to 5 ft), but I may have turned the Throttle P down too much.

Loiter:  Not so good ,but I haven't tried tuning yet.  I get oscillations and over shoots.

RTL: didn't work well, and seemed to mimic loiter in the over shoots.

One issue that I did notice was this strange uncommanded yaw of about 10-20 degrees when flying away from me.  Reading up on this thread makes me think that this is a known issue.  Since, I have the latest GIT, I thought this was resolved.  Maybe not?

All in all, great effort and results!  I am going to tune it up a bit and test again.  Of course this weekend has to be the biggest storm of the season in San Diego :)

Attachments:

... and the winner is........ the quad of JL! :-)
Nice loiter bro!

He is always a winner with his video's!!

Great job, as always ;-)

how do you pick what to use for alt hold? sonar or  baro??

Absolutely! :-)

I don't have a sonar, so it's an easy choice :)  If you do have a sonar, you can select if you have a sonar under the setup tab in the MP.

Just came back from flying Git version 2.5.  Quad did well, Y6 was worse than v2.4.1:( 

Calibrated mag, ESCs',  usual setup.  Used the same PIDs' as previous version with no luck.  Tweaked them some, and still no better.  Yawing bad left and right.  Try to give yaw input and it would tilt sharply in direction of input. Adjusted top bottom ratio, but no good. Sometimes it would not stop yawing after giving it yaw input.  It was as if it was drunk off of its stool.  

Version 2.5 was much better than v2.4.1 on my quad.  Y6 actually flew better on 2.4.1.  Will reload and run the setup again. Attaching a log if anyone wants to take a gander.  Y6, 650kV motors,  APM1 2560.    

Attachments:

Any news on the Y6 with 2.5??  I'm planning on testing it tomorrow on my Y6.....

I am reloading and going to try it again in about an hour.  Got the tri-pod and camera out to video it this time.  

Very nice !

I can't do GIT, could you be so kind as to email me the firmware you used ?

kuhng(at)vodamail.co.za

I need to set up a friend's quad, might as well do 2.5...........

Regards,

Gustav

Hi, is there a problem with 2.4.1 when using a quad in x-mode?

My + quad is very stable, part of my setup test is to advance the throttle to hover speed, and then holding it by one leg, the quad remains level.

When doing the same on a x-mode quad, it seems to first "lean" INTO the error, before trying to correct itself.

Both using APM 1, my quad is the old standard quad, the other one a make I don't know, but the motors, props, and physical layout/spacing the same.

Same code in both.

Thanks,

Gustav

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service