Version 2.4 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area.  Although not as big a change as the 2.3 release, it still includes a respectable number of enhancements and bug fixes.




Bug fixes:


The default PIDs are optimized for a 3DR/Jdrones quad with 850 motors and 10" props. If you're using more powerful motors/props, start by turning down Rate Roll P in 25% steps.


Thanks go to the numerous contributors including users and their detailed bug reports, developers and testers.  Hopefully all together this will add up to a nice smooth release!


As per usual, please post your comments, issues in this discussion.  For enhancement requests for future versions, feel free to add them to the issues list.  Note:  you can "star" an issue to receive emails when someone comments on the item.  On the dev side it helps us because we can get an idea as to which feature requests are the most popular by sorting by the number of people how have starred each issue.

Views: 64965

Reply to This

Replies to This Discussion

Hey Marco, what landing gear you use with camera gimbal? I'm after one for hexa. Sorry off topic. Ill pm you. Thanks heaps.

same question


Stefan, after the firmware upgrade try to reset the eeprom, logs and the APM (to default), then disable end enable again the compass.

Hi Paul, home made landing gear... :-)

Thanks Marco. I tried your suggestions and have it running now.

There may be an issue with locale in the APM Planner.

I live in Sweden and had to enter the magnetic inclanation like "4,20" instead of "4.20".

I changed my computer to US locale and entered 4.20 and now it works. If I switch back to swedish locale and do the setup again the readings fail.



Sorry. I was to quick. :-( Still does not work. Will try Arducopter 2.4 with my APM1 with 2560(Currently using APM2).

Yaw, pitch and roll are rock steady on my APM2 with latest Ardupilot




I tried 2.4 yesterday along with my new sonar and it flew very well (still not tuned).

However, I had a crash when I tried to land in ALT_HOLD mode - it hit ground with landing gear and went crazy. I didn't expect it to work  but I didn't expect it to react so violently - is it common knowledge that it's not a good idea or is it a bug? Maybe it would be a good idea to have workaround in case someone else tries this :-) or a minimal height in alt_hold?


      Any chance you have your logs and could put them here?  I don't know of any reason why it would do that.

2.4 is working really well. Flight from yesterday below:


But only with the APM1 1280.

APM1 2560 connects ok.

Started a previous version 1.1.16 and the APM1 1280 connect ok.

Sorry, no logs. I was running default PIDs on a wildly different setup, it wobbled a lot. When I tried landing it in alt_mode, it hit ground with one landing gear first and then just came wildly forward - I tried flipping to switch for stabilize but it was too late to do anything. Maybe it just overcompensated for the ground hit and tilt...

I was just wondering if anybody is landing in ALT HOLD - if it's supposed to work I can try it again (on soft grass this time :)) and find out what went wrong...

Presumably the 'easier to use motor testing' hasn't come to hexa yet? That seems to be the same as before (move the pitch/roll to indicate which motor should run)....

Reply to Discussion


© 2018   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service