Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!


Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.


The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.


Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]


Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]


PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).


Happy flying!

Views: 64326

Reply to This

Replies to This Discussion

Yes, it has been supported for a couple of versions now.

The soldering is a bit kludgy on an APM2, but it does work.

first chance to fly 2.6 this evening, and only briefly at that.  30 kmh winds gusting to 40 kmh and STAB was absolutely great, i tuned RATE P to 0.130 and STAB P to 4.3 - really very smooth and predictable on a 2Kg hexa (880kv and APC 12x3.8).

loiter wasnt particularly great, but then the conditions were difficult, im sure i can improve it tomorrow.  

the throttle range is _significantly_ wider, on first takeoff i almost left the ground while i was just spinning up the props to an "idle".  another effect i noticed is that the burst of throttle to stop a descent seems to need slightly more stick movement.

yaw was responsive but i had a little bit of rebound after turning, again im sure it can be improved as i was just starting to get some results in 2.5.5, today i flew with RATE YAW P 0.140 and STAB YAW 7.

lots of landings in blustery winds and i havent even broken a prop :D, really nice to fly, thanks all.


On my Y6 I found 2.5 to be very stable . I have upgraded to 2.6 today, the throttle range is better, the Y6 is alot more responsive to any radio commands, but it drifts more than when I had 2.5 installed. It also yaws on take off alot more.

 I cannot calibrate the compass in MP because every time I move the Y6 with the mini USB connected, I loose connection. I have read other APM2 users have this problem with the APM2 usb hub also.It is very sensitive to movement.

I attached a video and tlog (it's all I have of my first example) to a commend in the other thread:

Honestly looking at the logs again, I'm having difficulty understanding what was cause and what was effect. There are strange anomalies like an xacc spike for the first jerk, but not the second. In both cases there's a fairly large corresponding input (ch2) change, even though I was at most moving the stick a percentage of a degree to maintain hover.

I'm charging up batteries again, and will try logging as you suggest, thanks for the suggestion.

In 2.6 release I've got the default (0.1 I believe?). When I was diagnosing the problem with 2.6 Delta and before, I had tried dropping the stab I factor and rate D factor to zero. I also was experiencing the twitch in acro-only mode which I had assumed eliminated the stab PID settings completely. I've not tried anything but defaults in 2.6 release however, so I've got some repeat experimenting to do, and I'll try eliminating STAB I again now.

Tried v2.6 final with slightly modified PIDs (rate_p = 0.165) on my heavy hexa (4kg, 12x3.8SF, 4s, APM 2)

Wow, even in the breezy afternoon winds rolling off the coast, this thing is rock solid.  Slight bit of drift that could be  due to the wind or not a perfect level, but it's definitely the most solid feeling I have ever felt it.  I don't have much time on this hexa, but it was still all over the place with v2.5.5.

I get a bit of wobble in the yaw axis, and I may turn down my dependency on my mag.

Still very frustrated with my GPS.  9 sats today for well over 30 mins and no lock.  There is something up with my board.  Now, I am also not reading my dataflash card.  So, no logs.  Maybe the APM2 is just getting old (one of the originals)...

Hi all, I have a small problem with the v2.6
I have a coaxial octo, 850kW, 10x4.5, 1650 kilograms XAircraft frame.
I never had happened, with no code to maintain Hight altitude, the quad is directed toward up front when I get the quad so stable returns to its position.
it's like 10 and 11 engines accelerate more.
has explain me is not even the acceleration of the engines.
Otherwise it is perfect.

Code. loaded with Arduino: everything else default
/ *
* /

/ *
* /

Regarding the Spektrum equipment, I think there is a range of quality available. The current DSMX systems are, at least in my experience, a lot better then the early DSM and even DSM2 systems, where a lot of fliers got burned.

Update on the analysis:

First, I reviewed the failsafe behavior, and it's working fine: upon signal loss, throttle goes to Off (under 1000µs). So radio signal loss did not prompt the climb out.

Second, I checked and wiggled the receiver-to-apm wires individually, while connected to the planner, to see if there would be any loss or input signal based on a wire shorting out. No such think occurred, and the connections were all firmly in place.

Then I investigated the following:

I had a small tilt-camera mount on the copter (keychain cam on it), driven by a powerful servo (an old Multiplex Micro Speed), which I had just installed before the flight with the fly-away event. During the flight, the camera mount had been hanging loose, with no pushrod linkage on the servo (glue still curing on the pushrod), but with the servo active. Maybe the servo got caught on the frame in the wrong way and stalled in flight.

I tried this: while connected to the planner via USB cable (no battery on the copter), I manually stalled the cam tilt servo. This caused the receiver to flicker wildly (indicating frame losses, possibly a crash) and the APM to reboot, dropping the connection to the PC. The receiver recovered when I unplugged the camera tilt servo from the APM. I reproduced the same with a full-size analog Futaba servo as the camera tilt servo, which caused the crash/reboot but would let the receiver recover immediately. I also tried two micro servos in this manner, but stalling them did not disrupt APM and receiver. So there is a possibility that drawing too much current on the camera tilt servo was the problem.

Unfortunately, I have not been able to reproduce the same "current crisis" while running the quad off a battery, with running motors. The battery provides much more power then the USB cable, and without props, on the bench, the motors don't draw all that much. Running from the battery, the board is fed through the 2Amp BEC of a 20Amp 3dr ESC. These 2 Amp are driving the APM with all its sensors, plus the dual receiver, plus the 3dr radio, plus sonar, plus optical flow. Maybe, in flight, the "current crisis" scenario did occur when a big stalled servo was added to these consumers of power.

Umer - "stabilize" is not position hold. It is a mode where the 'copter tries to stay level, except for your inputs. It does not try to stay in one place. That you rose to 100 feet and came back down, traveling 200 feet vertically, and only 70 feet horizontally is very good. 

Consider even a 1mph wind, or even a tiny lean in the copter, you will get a lot of lateral moment. It is *because* you did not provide (correcting) inputs that your copter moved. In stabilize, it is like a hockey puck on ice, it will slide in any direction with very little force of wind or any tiny imbalance. 

You can read about all the modes at

Please read the notes about alt_hold at as most people switch it on and find that their 'copter drops to the floor quickly, because they did not read that.

And congratulations! 70 lateral feet in 200 feet vertical in a first flight while in stabalize is very good. You have a well built 'copter!

Just got a fright.   Loaded 2.6 from mission planner into APM2  did  a cli  erase and reset,  set +  and calibrated radio  set modes and thought I saved them, tweeked a couple of pids    and went out to  park to test loiter and its not so good but stabilize is  fine . Back to the house and check  and modes are all stabilize  so do a cli reset to  default  the pids and  set up modes , radio,   + and level again. 

 Back to the park and Quad is lifting off  in stabilize and hovering then flipping or flying off. 

Reloaded  2.6 from mission planner , cli erase ( no reset )  set up again and still acting bad.

Backed down to 2.55 and setup and its ok again, after  2.55 reload when entering setup it warned radio was not set up.


The greatness of the APM2 will be shown when just about anybody can easily do what Duran did in his videos...  what they show right now has a little more to do with his tunning than the automation of the APM2...unless the 2.6 pid defaults happen to be very close for his frames  ;-) !


Reply to Discussion


© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service