Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

Views: 64336

Reply to This

Replies to This Discussion

Thanks you, Mike. I had been reading the wiki page, but hadn't see the other thread. I currently have power through the output rail & diode.

The 300mA total headroom don't look like much to me to accommodate a digital servo, so I think I'll change to powering the board on the input / receiver side, separately from the output side. I also just ordered a decent BEC.

i got 1 problem about MP version 1.1.92  MAVlink 1.0

after write waypoint to APM2, i cannot click menu configuration,

attached screen shot error appear something like DLL missing.

i update again  MP, now can go to configuration menu, but if  write waypoint again, same error occure.

how to solve it.?

thanks

Ultojo.

it would be you have the kindness post your parameters I have one similar but with apm 1.4, 1.650Kg

Did you run Mission Planner from within the ZIP file without extracting the files? 

If so, please extract all the files from the ZIP to a folder, and *then* run mission planner, or go download the MSI installer for Mission Planner if you don't understand what I am talking about.

If not, go to "Help" and "Check for Updates", since something is missing.

I have ublox GPS; but how do I connect to a APM 2 which already has a GPS on it....

I am hoping to get the same accuracy of the demo videos done by randy

I have the latest, 1.1. I update the firmware fine, it seems to boot (see the logo and progress bar on-screen) and then it has the 'Update Charset' message at the bottom, even though I've done the update a dozen times and OSD Config claims success.

Hello, on the topic "Copter LEDs" where I find the documentation for how to connect the harness and control of the LEDs? thanks

Roberto

Works with APM2  but not with APM1 ... I've not find the problem with APM1

 

if someone have a solution for APM1 ?

tq Mike ,i will try as your suggestion.

Hi Dave,

i try change  speed to 3m/s, and tested in strong wind too slow move. so i will trying 5m/s not tested yet.

yeah sure,

use default pid 2.6 but update litle bid..

i still tuning it. still not satisfied , some time loiter stay well sometimes loiter circling..(all tested in strong wind condition)

Attachments:

Reply to Discussion

RSS

Groups

Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service