Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

Views: 64325

Reply to This

Replies to This Discussion

Hi Gordon and others,

I managed to squeeze 2.6 on to my 1280 yesterday, disabled  CLI, logging and defined MTK16, but had immediate problems getting the motors to arm.

Mission planner showed that rc was setup properly, had all channels connected and responding correctly, 6 modes saved and changing  on flight data screen.

But the rc connection seemed to be intermittent, and once the motors were armed the throttle responded very eratically, with the motors surging to full power, then stopping entirely at random.

Also although I had full GPS lock, the flight data screen seemed to be in delay, but did eventually show 3D lock. The red LED on the APM was not lit solid as it normally does when GPS lock is achieved.

Reverted back to software 1.0.49 and everything works fine again.

Does anyone have any ideas or suggestions please?

Kindest regards

Martin

Hi Martin,

I also tried to get 1.6 into the 1280 board, prior to this thread, no luck.

Neither with 1.5, which at the time tipped my hand to get a 2560 board from Sparkfun.

Just on two weeks later, after tax here, I had the board, for about $65.

Oh well, the 1280 board is going to be a superduper Arduino now :-)

Martin,

If you leave the gps to auto-detect, it will still fit in the 1280 with about 3k to spare. The red LED will  then light up solid. Got a short flight today before the rain came.

It would be nice to see this fixed cos 3k doesn't leave much extra space

I've just uploaded 2.6.

I actually wanted to start over fresh, but it seems that all my previous parameters and settings are still the same as my last settings.

How can I update to new standard PID settings?

There used to be a command eeprom clear (reset).

Apparently it's not done automatically.

 

Can some tell me how to do a clean install?

Tried out 2.6 yesterday in Stab, Alt-hold and Loiter. In general, pretty good results but I will need to tune all three to achieve results observed with others.  Here are my notes from yesterday.

APM1, Sonar, 880kv 3DR motors, 2Kg (with camera, mount and Tx).

1) Cannot get logs to work. 2.5.4 worked fine, but 2.6 will not write to the logs. Have Erased, reloaded 2.6, erased, reset and cleared logs 3 times. After each flight, when downloading the log, I get a message that says there are 19 logs but only two available for download. After downloading those two logs, each has two entries- the version string and amount of free ram. Has anyone seen this?  Do you know what I am doing wrong?

2) Stab mode is OK - some tuning needed for the 880kv motors and weight. Under 2.5.4, I had to raise RateP to .213 and StabP to 4.7.   I guess I need to start with the defaults and increase the values like I did with 2.5.4.  Does it make sense that I need to RAISE the values and not lower them?

3) Alt-Hold OK - some tuning needed for the 880kv motors and weight. Tends to move up and down a bit (+/- 1M) using sonar and more using baro. With 2.5.4, I had throttle rate at .45.    The 2.6 default is .25

4) Loiter mode is VERY good at first but after a minute or two, it starts to circle with increasing diameter circles until I have to reel it in. There was a light winid at the time.  Can someone give me a hint at where to start to tune out the increasing diameter circles behavior?  Start with Nav WP or Loiter P and I?  Maybe give it a little Loiter I?

Overall pretty good, but still needs some tuning.  And what’s up with the logs?

As always – many thanks to the dev team – you guys are the best!

 

After uploading 2.6 on my Y6, I have made this video in stab mode. It does'nt like hovering low. It goes up no problems, but reduce the throttle a little and it just wants to land. Overall its very good, maybe a little too glitchy for my 880kv motors and 12x3.8 props. 

http://www.youtube.com/watch?v=jzmFsOQhSjA&feature=youtu.be

Thanks for all your responses,

I loaded 2.6 again today with CLI and logs disabled, no problems loading, even without relax patch.

But although the throttle is better, it still lags behind the stick movements by half a second or so. Does anyone else experience this? (Futaba 9CAP on PCM mode)

I can get a GPS lock no problem, the blue LED on the GPS is rock solid, but the red LED on the APM does not come on solid, it lights at random.

I'm not keen to fly without the red LED being solid to show a good GPS lock by the APM. I have the throttle set to cut if it goes out of radio range, but don't really want to get into this situation.

Martin

Wind dropped finally and could take the 2.6 out for a flight.

Did only stable, AH and a little bit of loiter.

Stable is very good. It seems to react to drift and corrects itself.

AH is not so good. I'm using the XL-EZ0 sonar and in the beginning it reacted very slow when I put my hand under it.

At the end it could quite hold altitude when below 3 meters.

Attached are the logs and you can see that the sonar works correct.

 

Attachments:

Duran DeV: Glad to see the APM2 working out for you. Could you share your PIDs for your large videography octos? I am looking for the smoothness factor. I think I have it fairly close but it is always nice to compare to someone elses. I also fly a large octo... mine is 1.6 meters diameter.

Circling loiter indicates that the compass calibration is not good enough. I found that flying a two loop rectangular Auto mission and using that log to set the compass calibration really works will. Also check that you declination is set correctly for your location before you do the compass cal flight (I don’t use auto declination).

You can erase the memory from the Terminal page then load the firmware.

I have two AMP2 boards.  I have both uninstalled currently and my first board is all in one unit, the second one has a separate GPS.  Both boards have nothing connect to them.   The first connects and shows GPS info in the terminal test window.  The second one which is new and never installed, gives a time out message in the terminal test window for GPS.  Is there a need to enable GPS when you get a board with no headers and a remote GPS? 

The GPS has the blue on solid.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service