Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

Views: 64347

Reply to This

Replies to This Discussion

I can't seem to get Auto Approach to work on 2.6.  It was working when I was using 2.5.5.


I set RTL_LAND to 0, APPROACH_ALT to 5m  and my quad always enters LOITER mode when it's doing RTL.


I also notice that RTL ALTITUDE doe not work.  I've set it to 20 and it always comes back at the altitude that it was at when I flicked the switch.


Are these functions working?

Thanks for the time and effort working on this project guys!

Best regards,

Ronnie

I also feel that RTL ALTITUDE does not work.  I've set it accoring to  Marco Robustini's suggestion , set it to above 21 and it always comes back at the altitude that it was at when I flicked the switch.

I also modified the APM_Config.h

added this line

# define ALT_HOLD_HOME      10  // height to return to Home, 0 = Maintain current altitude

and re compiled it.

still no use at all.

 

Tangtl

 

 

 

 

I don't think RTL Altitude is working in this release. I meant to fix it sooner, but as of right now I think it is disabled. AUTO_APPROACH, however, should work fine. Nothing has changed there.

Ditto for me, RTL is not working correctly, mine just tries and comes back at the same alt, and pretty quick as well!! ANy ideas

The only way I have been able to get to it is to connect to the APM using a terminal program, hitting enter 3 times for CLI.  Then type "test", then run the sonar tests in the APM.  It works pretty well, shows you a reading as you move the craft around.  Hope this helps,

Rick

RTL for me it's working fine with AUTO APPROACH, it goes down to the AUTO APPROACH ALT, however, for that to work you must have AUTO LAND ENABLED. So, it detects you want auto land, but lands only to the auto approach alt. RTL ALTITUDE I don't know since I've never used this function. I thought for the AUTO APPROACH to work I should have AUTO LAND OFF, however, after 2 test flights, I noticed it had to be on. In an auto mission with a regular last waypoint, however, if I have AUTO LAND ON, it tries to land ignoring the AUTO APPROACH ALT, I've reported that, but I must get some logs to show. 

I tested yesterday with the following PID value:
Stabilize P=3.4
Stabilize_pitch_D=0.12
Stabilize_I=0.002
Rate_roll/Pitch left unchanged.

Now it flies very well, only a little bit nervous, I'll add little expo on the Pitch-roll.


Many thanks,

Mario

Sorry, didn't received an email with your previous answer don't know why. The 12x6 may have better performance, but only at higher RPM, and they may be stalled for most of the time, since in hover you don't need too high RPM, getting your bird unstable, the 12x3.8 may have less efficiency but give you a more stable platform and also more smooth reactions since the volume of air bitten in each rotation is a lot less, so they will be more accurate :) Glad to see you're flying ok now, you may also want to try your RATE D at 0.001 and RATE I at 0.010 just to see if it responds better.

Yes, I believe what is happening is this:

You start the flip facing north.  When the aircraft is inverted, it is now facing south.  When the pilot pushes the throttle stick back up to stop the flip, he accidentally nudges just a small amount of yaw, even the smallest amount.  As soon as that happens, the yaw controller accepts "south" as the new heading.  That's a defect in the controller.  When you complete the flip, you are facing north again, but the quad now things it should face south, so it begins to spin to face south.

That's my theory anyway.

Does the yaw stop if you touch the rudder stick soon as it starts to turn?

Aha... ok. I saw your bug report and accepted it. This information really helps. I will look into this tonight. Auto Land should not have to be enabled in order to use auto approach. I will fix that as well.

Regarding the Auto missing... what is your last waypoint set to? Is it truly just a regular waypoint?

This should not have been working in the previous release either. The code was commented out and brought to my attention by Marco R. I haven't had a chance to re-enable it (not sure who commented it out in the first place). I am setting some time aside to look into this issue and the minor auto approach issue reported by Rui Manuel Cravo Marques.

Yes Adam, I just create a mission with 5 or 6 points, all equal in parameters including altitude. I don't know if that information is on the logs saved by the board since I don't have radio telemetry for the moment. I'm waiting to see if I can get a windless day to tune loiter better and also film the auto mission with the reactions and get the logs from the board so you can analyze it better. First I thought it could be from flying with just baro, but my baro is keeping altitude pretty well, so even if it dropped 1mt it shouldn't touch the ground, but it tries to land. Hopefully I can get some more detais in video this weekend.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service