Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!


Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.


The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.


Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]


Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]


PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).


Happy flying!

Views: 64329

Reply to This

Replies to This Discussion

....hard mounting the camera will get you good video if your quad is smooth.

i will try to do hard mounting the gimbal.

thanks for your suggestion Matt.

thanks for the tip Rui.

i thought they make smooth video by quad without editing..

I have an issue with GPS...

I get a solid blue light on the GPS Unit, but the mission planner (connected via Xbee)

does not pick up GPS signal.

0 satcount, but solid blue light...

Im at a loss!

I have had that problem randomly also. It has been around since the 2.5. Sometimes it displays satcount and sometimes not. I think that it is recorded but just doesn’t display correctly all the time. If I restart the mission planner and play back the log it most always displays satcount. I have had the same random problem with the % throttle. Most of the time both work but not 100% of the time.


I get that, But in my case, It does not show my GPS location on the flight planner page.

Dont think loiter will work too well!


   I have some problems with logging.

Some time is working, most the time not.

Usually I get following messages:

Init ArduCopter V2.6

Free RAM: 2346
FW Ver: 118

load_all took 7768us

Press ENTER 3 times for CLI

GArduCopter V2.6] logs

8 logs
Log 1,    start 1,   end 1
Log 2,    start 1,   end 1

I erase all and get:

Log] !!Allow 30-90 seconds for erase
?3 ?Erasing logs                                      ???3?Log erase complete                                logs enabled:  ATTITUDE_MED GPS PM CTUN NTUN CMD

No logs


After flying get again first message...

Any ideas?

  I’m  setting up my APM2 with V2.6 software on a Tricopter V2.5 with DT750 motors, 9x5 2 blade props, 20 AMP Hobby King Blue series ESCs and a 3cell lipo  .  I have the yaw pretty much sorted out and it  flies well in Acro and attitude modes on the stock parameters.
However I have a trim problem in Acro mode. With the stick neutral it tries to rotate backwards and I have to use about 3/4 of the available trim for it to stay put. It seems that the controller is not seeing the the neutral position on the stick as neutral.
I have tried the following
1- I recalibrated the radio twice.
2- I recalibrated the ESCs.
3- I swapped the rear motor with a one from the front 
4- I checked the C of G and tried moving it forward and this helped a little.
5- I moved the forward arms backwards about 20 degrees each and I could get rid of the trim but it still feels like it is not seeing the neutral position properly.
6- I put my rabbit controller back on put the C of G and the arms back in the right place and it still flies fine.
Any advice would be appreciated

Sounds like you just need to auto-trim it? I'm not sure if auto-trim has any effect in acro mode though.

Easiest way to auto trim is to set it to activate with the ch7 switch, then fly in stab mode giving small bumps on the sticks in the direction it needs to be trimmed until it will hover with minimal drift (in a windless environment).

Does auto-trim stay in effect until you turn ch7 back to the low position?  Or does it time-out?

Seems like it's in auto-trim mode while the switch is high, then turns off when the switch is low again, but I may be wrong.

have you gone to the "configuration" button and "level" in the mission planner with the copter connected to the pc while it remains at rest leveled in a plain leveled surface ? That looks like offsets not calibrated. Use a bubble level and some sort of card pieces under it to level it and use the bubble level to measure from motor's top to motor's top, then when you have all the 3 motors leveled (or very near), hit the level button on the planner, and try to see if it's better. Use the auto trim only after that to do some small corrections, however, auto trim must be used in a windless environment, or any adjustment you make, will turn against you when the wind changes. I don't need auto trim after using the level command and I have a cog away from center.

I think auto trim is for the accels. It flies fine in stab mode with no trim. It is the gyro that is the problem. I tried trimming it in Acro with the TX and then recalibrating the radio. It saw the new position as neutral and I still had to hold forward stick.

Reply to Discussion



Season Two of the Trust Time Trial (T3) Contest 
A list of all T3 contests is here. The current round, the Vertical Horizontal one, is here

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service