Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

Views: 64314

Reply to This

Replies to This Discussion

Sketchbook is OK.

Where this log function (in which source file) is supposed to be? I can't find it.

hi georg
could you please give us some information about your arducopter such as what motor,prop and Also wight...?
is alt hold works with these parameters?

I realize what the problem is, unless you have a GPS lock none of the modes that use GPS will show up, they all just default to Stabilize.

Thanks shayan, figured it out

Tried 2.7 today, and saw a clear improvement over previous loads in the loiter, waypoint, and RTL performance (stabilize was fine in  2.6 for me.)

1. I am using a standard 3DR quad with the small motors, 10x4.7 props, 3300mAh 3S battery.

2. Did a full reset so that all PID gains were reset to defaults.

3. Loaded my previous RC channel limits and basic H/W configuration parameters (editing a .param file and keeping only the lines with basic setup parameters is a great way of being able to get the system running again with new firmware).

4. Flew five batteries worth of basic stabilized flight, alt_hold, loiter, RTL and waypoint missions.

a. Bumped up my altitude hold thrust rate P gain by 0.2 to 0.5, and lowered the rate P gain to 0.15 from 0.18. No other PID changes.

b. Loiter was holding within 2-3m in winds of 15-20 km/h

c. RTL brought it back reliably down to the ground (with the APPROACH_ALT at 0). I have a tight cleared area, so had to give it a bid of a nudge right before touchdown a couple of times, but pretty good considering the wind.

d. Waypoint navigation wasn't tight, particularly when making 90 degree corners but, again, the wind may have been a factor. However, it did work each time, and did hit all of the waypoints.

I am still using a code mod that adjusts the compass offsets as a function of motor current. I found that necessary in earlier loads to avoid divergent circling loiters (never seemed to get a good dynamic calibration with the standard approach), but will try without next time.

The impressive thing with 2.7 was the minimal PID tuning required to get good performance. I haven't seen that in previous loads. Thank you to the developers.


Andrew

Solved!

Well when I tried to compile it with arduino 1.0relaxpatch it's OK ;o)

I used arduino 0023 relaxpatch and it is bit outdated. This log (function or macro) must be defined in latest arduino libraries.

I have updated MP to 1.1.99 mav 1.0. When entering APM setup window on Parameters List page I can see only selected value, all others are white (background and text font of each cell).

Is that only matter of setup? If yes, then where I can set it to previous colors?

Thanks Andrew for your report.

I have a query regarding arducopter 2.6:

For 880 Kv motors, value of Rate Roll P should be 0.09-0.1 (as stated in wiki) or 0.110 (as mentioned in mission planner Med P = 0.110) ?

I have the same, it's not a matter of setup

Start with the default value, the wiki is a little outdated for those values.

Flew v2.7RC this morning, very nice. Auto, Loiter, RTL work very well. In Loiter there are some medium frequency oscillations which don't seem to affect the Loiter but would definately upset any aerial video takers. Otherwise great job devs, looking for to v2.7 final!

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service