Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!

 

Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.

 

The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.

 

Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]

 

Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]

 

Tuning:
PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
 
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).

 

Happy flying!

Views: 64327

Reply to This

Replies to This Discussion

I have calibrated the level mode and if I fly in stab mode there isn't a problem. Acro mode is where the trim changes. I can trim it in Acro with the TX and it is fine but that is a problem for the other modes because they see the trim as a control input

Bob 

Did you tried to increase rate_pitch_i until it stop leaning ? (you may have to verify that Imax>0).

My rate I settings are actually greater than rate P 8) But it works a treat. (on pitch : rate kP=0.18, rate kI=0.19, doesn't fly well in acro anymore since I dialed kP down but rock solid in stable. The rate I param was tuned when flying in acro mode)

Good luck !

Having a strange RTL issue with 2.6 : when activated, my tri always bank toward an apparently stochastic direction and maintain it's angle until I switch over to stab. I have the APM2 with stock MTK GPS, and a well tuned loiter. MinimOSD should display an arrow showing home direction and distance but doesn't, so I don't know if it's osd-related or AC having trouble to set the home point. Is there any way to tell where the home location is with telemetry and MP ?

I still have an issue with GPS... I get a solid blue light on the GPS Unit, but the mission planner (connected via Xbee) does not pick up GPS signal. 0 satcount, but solid blue light... My GPS location does not show on the mission planner.

I am running APM1 with 2.6 (modified for octo quad)

Any help would be appreciated.

Thanks

graham,

i occasionally have this problem and in my case i suspect the cable is the cause.  whenever this occurs i power down APM, reseat the GPS cable, and start it up again.  as far as i can tell this solves the problem pretty much every time.

james

Thanks I'll try that later today.

Bob

Thanks I will do another inspection

Exactly the same problem I occasionally have. Solid blue but zero sats reported in MP. I unplug main power and reset gps connector and restart. Solves it maybe 100% of the time but I'm not sure if the problem was the cable. Have to test if a restart is all that is correcting it. I'm using latest arduplane code. Haven't noticed the problem on my quad but it might be because I'm flying it less often.

I was getting a very similar problem. After a flight my logs were always of a historical flight and not the current flight. I did a reset and erase through the terminal setup then reinstalled the firmware and setup. Now my logs are working again. I think the 2.6 changed the way the logs erase and the old log information was not erased properly.

Emile L.

Just an update on my needing forward trim in Acro mode but not in level mode. I solved the problem by recalibrating the rear motor ESC high end to 82% this makes it run faster at any throttle setting. It didn't change level mode at all.

Bob 

Wow, that's an ugly fix ;) Hope it will not go forward or shake at WOT. Does it ? Increasing the pitch rate I did help a bit or was completely ineffective ?My tri may have a CG very forward when adding some batteries for "long duration" flights, but it still does maintain the desired angle in acro mode. I hope yours will not go nuts if you change the CG.

Robert,  I have the exact same issue as you, and I think it's really CG sensitive.  My CG is slightly aft right now, and i get that rotation in acro mode.  I currently run with no rate_i, but i may try adding some.  

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service