Version 2.6 of the ArduCopter code is now available in the AP Mission Planner and in the downloads area!


Updates to MavLink 1.0 means you will need to use "ArdupilotMegaPlanner10.exe" to connect.  If you've updated your mission planner recently you should find this executable in the directory where the mission planner is installed.


The above video is done using a prototype 3dr ublox GPS which seems to have better accuracy than the standard mediatek.


Improvements over 2.5.5 include:
     - MavLink 1.0 support (use with ArdupilotMegaPlanner10.exe) [Tridge, Craig]

     - Stability improvements especially during level hover [Jason]

     - throttle range improvement (higher min and max) [Jason]

     - improved standard Loiter PIDs [Alan, Heino, Jason, Angel]

     - dataflash erase speed up ('+' messages removed but it only takes 6 seconds now) [Tridge]

     - Copter LEDs [Robert Lefebvre]

     - RTL loiter stage target set to home to improve final landing position [Jason]

     - flip & acro improvements [Jason]

     - circle mode target improvement for ground station [Jason]

     - Auto Approach [Adam Rivera / Marco]


Bug fixes include:

     - UBLOX driver fixes (lock should now be more reliable) [Tridge]

     - enable mavlink messages during dataflash erase which resolves issue in which new APMs fresh from the factory appeared unresponsive [Tridge]

     - proper printing of lat/lon values in dataflash logs [Randy]

     - removed duplicate GPS reads [Jason]

     - resolve flooding of telemetry link with low-battery warnings [Tridge]

     - RTL bug would land if rtl_approach_alt was more than 1 [Jason]

     - WP Radius could not be set larger than 1.3m [Jason/Randy]


PIDs are optimised for the 3DR/Jdrones quad with 850 motors and 10" props.  If you're using more powerful motors/props and are seeing bad flight behaviour in stabilize, start by turning down Rate Roll P in 25% steps.

This time we spent some time optimising the loiter PIDs.  Tuning loiter can be tricky so please refer to the discussions which will appear below for more community feedback on what parameters work best.
All feedback welcome below.  Enhancement requests and bug reports can be put into the arducopter issues list.  When possible please include logs (tlog and/or dataflash) and tell us whether you're using APM1 or APM2 and what version of the software you're using (presumably 2.6 but tell us anyway!).


Happy flying!

Views: 64370

Reply to This

Replies to This Discussion

I see there is still a bit of bounce on auto landing. This happened in 2.5 to me  and it took about 4 to 5 bounces along the ground before it would stop. Because of the bouncing and some wind it flipped over a few times and broke numerous props. Has this been reduced in 2.6? Is there something that can be tweaked to lessen this affect?

Typically we see the quad drop out of the sky (motors off) on DSM2 signal loss pre 2.6.

I see a DSM2 drop once every month at least.

Look forward to using 2.6. Problem is I now need to port all my MAVlink code!

Fixed: loading the code again. cleared the arduino library and copied and pasted again, 3 compilations 2 deleted 1 reset.
That something in memory stay the error occurred.
success with v2.6 very good response so far.

There is an idea I like, I'm on the possibility of placing two sensors Pressure in the skates, and as fit only in the auto landing.
it may adapt something?

wow yes!! this could also initiate a power kill for not only landing but also for flip overs to reduce prop and motor damage. How would you suggest to connect it to the APM?

Autolanding with hexa/y6/octo/x8 is not recommended (imho), instead use autoapproach.
If the quad is pretty big bounces are obvious, autoapproach allows you to bring the quad in front of you and to land safely manually.
With Mikrokopter and Wookong the same thing happens, the only advantage is that these systems having amazing position hold and the descent does not make any drift, so the quad is difficult to flip at the ground because don't drift when touch.

Hey Chris, is there supposed to be a new CharSet for MinimOSD 1.9 w/ 1.0 Mavlink? I updated to 1.9 w/ 1.0 and it booted and said "Update Charset" so I got the 19 zip file and updated with that mcm. The update succeeds according to the OSD Config app. Still says 'update charset' when I install and boot it. So I tried flashing the 1.9 w/ 0.9 Mavlink, then the charset then 1.9 w/ 1.0 and I still get the same thing.

Is there something special that needs to be done?

as mentioned be

Is the Optical Flow Sensor already supported in 2.6?

Been away for a while and just had my first flight with 2.6 on an old 1280. Planner 1.1.92

Great work team stabilize was impressive.

Noticed a couple of things though.

1. Everything up to 2.5.5, I could make fit by defining MTK16. This is the first time I have had to disable CLI, so I couldn't find a way to do an erase and reset in the planner. Had to reload 2.5.5, erase, then load 2.6 and do setup. Did I miss something obvious somewhere?

2. Now here is the weird one. With the Define GPS MTK16 line in place, the planner would only report 3D lock over USB. Over xbee it just said NO GPS. Removing the MTK16 line fixed it all up. I would like to still use the MTK16 in the Config.h for when the code starts to expand again in the future. Like a lot of people, I'm on a tight budget and would like to milk the 1280 as long as possible.

LED_Mode = 9  I change to 0 same of my previous param but not work. 

the piezzo is on AN5 for the moment same before.

What revision is your minimosd board Luke? Mine's 0.1 and the GUI says the firmware ours being adopted correctly but it just doesn't work. I would be keen to try and reflash it with the firmware it shipped with, but I'm not sure if the firmware in the downloads section perhaps doesn't work properly with this revision board.

Reply to Discussion


© 2020   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service