ArduCopter 2.7.1 will become available on Mission Planner and in the downloads area shortly. This release contains a few important bug fixes as well as the first implementation of the MPU6000 sensor-fusion code. 

Detailed changes are in the commit log. Here's a summary:

New:

- Preliminary support for MPU6000 on board sensor-fusion (DMP)

- AP_Limits: Experimental "bounce" mode, for smaller spaces (LIM_RECMODE)

Bugs:

- Bug fix for yaw error buildup on takeoff

- Fix in Auto mode for failsafe handling

- Fixes to 3-axis camera gimbal code

Views: 37179

Reply to This

Replies to This Discussion

I have made the first trials and it appears that if i arm the motors and i do not move the sticks for around 25 seconds the motors will disarm automatically. Is this a new safety feature installed or i have some issues ?

FUN FUN

 Loaded 2.7.1  APM 2     PM  1.2.2

Now quad will not arm,  

telemetry is working 

Radio is calibrated

ESC calibrated

APM can see RC radio

tried full right and full left  in case reversed

It's a simple mistake... Dual Rates OFF?

Yes it is. That's a safety feature active since version 2.2 or so.

yes DR is 0

I have APM 1.  There's no mistake, my hexa flew fine prior to the update.

Well, I'm really stuck in a rut with this one.  I've tried reloading the firmware umtenth time after clearing the EEPROM and doing a factory reset, but I'm still stuck with no signal on output channels 7 & 8. 

Checking the frame type under the CLI confirms a proper hexa configuration, yet I'm only getting 4 props to spin.

Any ideas anyone?

Connect usb to the apm with rc receiver working (but motors unpowered or props removed) and connect mission planner.

In mission planner, flight data screen go to the lower left pane and select "status" tab.  There you can see the values of all input and output channels.  If they move there, but nothing comes out of the pins, then you have a hardware problem.

If chan 7 and 8 don't move in mission planner either, then you have something misconfigured or misconnected.

Attachments:

Mode-Switch is in Stabilize?

Have you tried recalibrating the ESCs on the two that aren't spinning? 

I updated just my copter and notice on take off that with this firmware you can tune motor speed to zero and also spin them with so slow rpm that half of motors shut down.

Anyways it fly well and takeoff & landing was wery smooth BUT when I switch off altidude hold and it goes up because too mutch thrittle. I reduce throttle and suttendly it cut off all motors and copter drop groud as wet wipe. I need build new copter because it was total destruction :(

I just try download logs if I get some answers why it cut down power, but some reason that log downloader does not work.

http://youtu.be/pZkNGRJBKOk

I still try download log from crash

when I go to "Log Download" I got following console log:

Init ArduCopter V2.7.1

Free RAM: 1485
FW Ver: 118
----------------------------------------


load_all took 9412us

Press ENTER 3 times for CLI

GArduCopter V2.7.1] logs
logs enabled:  ATTITUDE_MED GPS PM CTUN NTUN CMD

190 logs
Log -23807,    start 1,   end 15
Log -23806,    start 16,   end 16
Log -23805,    start 16,   end 16

Log]

But on left list I dont see any files. So how I can download these 160 files?

Also another question is that is this special look microSD card normal? Can I use normal microSD card what fits to reader. I dont see point why this use custom card.

Reply to Discussion

RSS

© 2019   Created by Chris Anderson.   Powered by

Badges  |  Report an Issue  |  Terms of Service